Skip to Content
0

Hide language option in Fiori Launchpad logon screen

May 12, 2017 at 06:53 AM

464

avatar image

Hi ,

I have removed the check of Language in system logon display by navigating to SICF path: /default_host/sap/bc/ui5_ui5/ui2/ushell -> Error Pages -> Configuration

However, it is still visible on Launchpad. What am I missing ?

Also what should be done to remove the change password button ?

Regards,

Janani

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
Janani Rajagopalan May 19, 2017 at 09:17 AM
0

Hi,

There was an external alias for service /default_host/sap/bc/ui5_ui5/ui2/ushell pointing to /bc/ui2/flp in my case.

The external alias had "use global settings" as settings selection. So I had 2 options to choose from - 1) Define service-specific settings for the alias. 2) Change configuration of service flp which has service specific settings and unmark language checkbox.

I opted for 2nd method thus unchecking language option from both services and the issue is fixed.

Regards,

Janani

Share
10 |10000 characters needed characters left characters exceeded
Tong Ning May 18, 2017 at 01:21 PM
1

Please deselect client in web service /default_host/sap/bc/ui2 -> tab Error Pages -> subtab Logon Errors -> System Logon Configuration.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member May 12, 2017 at 09:16 AM
-1

Hi Janani,

Regarding removal of "Change Password" button, you could hide it using CSS.

The CSS file for the login page is set to a file in the mime repository. The file name is “template_css.css” and the path to it is: “/sap/public/bc/ui2/logon/”.

You can hide the button by making changes here.

Regarding the language option, from what I can see in your screenshot, the changes are fine.

Did you try clearing cache, and accessing the application again?

Best Regards,

Rohit

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi Rohit,

Language option is still visible despite clearing cache. While saving, the options are 'ok', 'cancel' and 'Save as Global Setting'. Should I try the last option ? Any adverse effect to it ?

Regards,

Janani

0
Former Member

Hi Janani,

Have you selected 'Save as Global Setting'?

Let me know if you are still facing the issue.

Best Regards,

Rohit

0

Yes Rohit. The issue still persists.

0
avatar image
Former Member May 12, 2017 at 03:21 PM
0

SICF changes don't reflect immediately. Cache has to be reset or you could deactivate and activate service.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Kupporeddi,

SICF cache as well as deactivation and activation of the SICF service was attempted but to no avail.

Steps performed where as per link : https://blogs.sap.com/2014/11/05/simple-steps-to-configure-fiori-loginlogoff-page/

I have also selected 'Save as Global Setting' and then clicked on 'OK' button but the effect is same.

Regards,

Janani

0