Skip to Content
avatar image
Former Member

BO SL SDK - error with certain business layer

Hi ,

I am trying to extract UNX dimension id and its formula using semantic layer sdk. I I am facing couple of issues: I following codes as mentioned in sdk references.

SL SDK based in 4.1 ; jre 1.8,have added -Dbusinessobjects.connectivity.directory param , have added PATH variable C:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\win32_x86,

even with jre1.7, below issues were present.

1) When a unx is retrieved, I am unable to upload the business layer as the .blx file(business layer) has space. within its name. How do I load business layer with spaces in its name?

I tried renaming the .blx files by replacing space with underscore(_) , it worked ,but at times to get data-foundation layer with same logic it failed.its a bit inconsistent.

2) After retrieving .blx files to local drive , I get below error, is there any work around? As I need only details on objects and its measures ?

com.sap.sl.sdk.framework.SlException: Unable to retrieve the connection from the repository. Check if the connection exists in the repository and if you have the necessary rights. (IDT 15025) at com.sap.sl.sdk.authoring.local.internal.services.LocalResourceServiceImpl.load(LocalResourceServiceImpl.java:140)

3) For certain unx , I get following error.

Exception in thread "main" java.lang.NoSuchMethodError: com.sap.sl.tools.qt.QtSqlQueryLovHelper.detectColumns(Lcom/businessobjects/mds/datafoundation/lov/SQLQueryLov;Lcom/businessobjects/mds/services/relational/SolvedRelationalConnection;Lcom/businessobjects/mds/services/solver/IConnectionSolver;Ljava/lang/String;)V at com.sap.sl.sdk.authoring.businesslayer.internal.emf.impl.MdsSdkLovPromptConverter.convertLovs(MdsSdkLovPromptConverter.java:155) at com.sap.sl.sdk.authoring.businesslayer.internal.services.MdsToSdkBusinessLayerConverter.createSdkModel(MdsToSdkBusinessLayerConverter.java:190) at com.sap.sl.sdk.authoring.businesslayer.internal.services.BusinessLayerModelToModel.createSdkModel(BusinessLayerModelToModel.java:31) at com.sap.sl.sdk.authoring.local.internal.services.LocalResourceServiceImpl.createSdkBusinessLayer(LocalResourceServiceImpl.java:191) at com.sap.sl.sdk.authoring.local.internal.services.LocalResourceServiceImpl.loadInternal(LocalResourceServiceImpl.java:172) at com.sap.sl.sdk.authoring.local.internal.services.LocalResourceServiceImpl.load(LocalResourceServiceImpl.java:134) at com.bometa.universes.BobjIndvUnxExtract.extractSemanticLayer(BobjIndvUnxExtract.java:137) at com.bometa.universes.BobjIndvUnxExtract.getDetailsOfUnv(BobjIndvUnxExtract.java:89) at com.bometa.universes.Bobjunvextractsl.getDetailsOfUNXUniverses(Bobjunvextractsl.java:94) at com.bometa.BOBJmetaextactor.main(BOBJmetaextactor.java:39)

Please advise

Thank you .

Regards,

Pamod

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

0 Answers