Skip to Content
0

RunningMax(date) returns a string

May 11, 2017 at 05:41 PM

40

avatar image

Hi all,

I have a weird issue (makes me think it's a bug) with 'RunningMax()'.

When I do RunningMin from a date/time field, I get a date/time as result.

When I change that identical same formula to "RunningMax" however I get a string...

I have no idea why...

I'm on WebIntelligence 4.1 Support Pack 7.

Anybody have any ideas? Or suggestions for a workaround?

Thanks!

Bernard.

runningmin.jpg (35.7 kB)
runningmax.jpg (36.6 kB)
10 |10000 characters needed characters left characters exceeded

I have tried in BI 4.1 SP08 and it's working fine.

As a workaround use todate() function to convert string to date

0

Hi Amit - thank you for the reply - I'll ask our IT guys if there's any chance to test out SP8

Re the 'todate()' - I had tried that but the issue is that the string only has the date, not the time... So I can convert the string to a date but I then lose all the time information...

0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Bernard Deprez May 11, 2017 at 05:48 PM
0

And forgot to mention that a normal "Max()" on the same field returns a date as well...

Share
10 |10000 characters needed characters left characters exceeded