Skip to Content
0

Rant: FLP Target Mapping Resolution fails --> Problem analysis seems impossible / zero transparency

May 11, 2017 at 02:32 PM

164

avatar image

Dear Flower-Power-Gurus,


System: Information:

Using a Gateway System as means for a FES (prev. AKA Central Hub Deployment) on NW 7.5 SP5 with SAP_UI 7.51 SP1.
Our WDAs run on an ERP Backend System which is a good ol' Business Suite, no HANA involved whatsoever.


Background:

I am currently taking my first steps with the Fiori Launchpad designer, trying to integrate all applications that we currently use in our Enterprise Portal (90% ESS/MSS Stuff) into our newly founded Fiori Launchpad (navigational-wise). I attended the UX100 a couple of weeks ago, thus I think I'm not completely daft using the respective techniques - still a newbie, though.


Problem:
I have succeeded in calling WebDynpro ABAP Services via Tiles/Catalogues on the FES from the BES (ERP) with means of Target Mappings via TA LPD_CUST, however I would like to get it working as well with the "recommended by SAP"-approach, i.e. directly via the FLP-Designer and Intent-based Navigation. As an implementation guide I used the following white-paper:

https://wiki.scn.sap.com/wiki/display/SAPMOB/How+to+Add+a+Web+Dynpro+application+to+Fiori+Launchpad

The Major problem is, of course, that it doesn't work. I.e. I'm getting a JavaScript Error:



Still, this isn't what's making me particularily mad, but rather the fact that I feel completely helpless trying to find out WHY this error occurs and with "why" I mean I would like to debug the source logic (whatever and whereever it is) and see what exactly goes wrong during the resolution process.

In Before: The HTTPS-Connection to the Backend works, the intent is maintained cleanly, there are no typos, etc.

Allegedly, I'm supposed to be able to see in the application log (SLG1) what's happening, but there are no logs for that particular problem (I triple-checked I didn't mess up the log-selection, there really are no log-entries), subsequently /UI2/FLIA does not contain any error logs either. I've tried sap-ui-debug=true, but that doesn't really seem to do anything either, i.e. apparently I cannot debug in the browser what's happening. I can't debug the Fiori Launchpad itself either (maybe the idea itself is folly), because it's executed via the ushell sources which don't have any debuggable repository objects. My last resort ST01, of course, didn't help either. All the relatable content I found via Google/onedx-search lies zombified and unanswered in the depths of the interwebs or had a misconfigured RFC-Connection as a root cause.

All this make me wonder: Whatever happened to "set external breakpoint" and transparency? The root cause is probably something stupid and trivial because I lack experience, but momentarily, I don't see how I am supposed to continue my analysis.

This picture here, pretty much sums it all up:


Any help is highly appreciated. Thanks for reading -.-

Cheers, Lukas

P.S. I am not "delighted" at all >:-(

frust.jpg (36.9 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Keith Nunn
May 17, 2017 at 04:20 PM
1

Hi, Lukas.

Could you please give /UI2/FLIA another try? When you run it for "ZLeaveRequest-create" be sure you're specifying your user (this is default) and that you're checking the box "Restrict to assigned roles". Check in Customization layer first. If no results are returned it means that no roles that contain the target mapping are assigned to your user. If you do get results, check that the status indicator of the results shows that it's good.

If you are able to export the results and provide them here, I'd be happy to review them.

Thanks,

Keith Nunn
SAP Product Support

Share
10 |10000 characters needed characters left characters exceeded
Lukas Weigelt May 18, 2017 at 04:26 PM
0

Hi Keith,

thanks a lot for your reply! I followed your recommendation and attempted to select logs via /UI/FLIA once more and curiously enough, this time I got results, which is good, I guess, but it bugs me that I didn't do anything different last time (or at least that's what I think -_-). In any case, this is how I did the selection (wish I made a screenshot a week ago, too, to compare.. -.-).


And here's the result for the respective catalogue which is throwing the error I posted in my opening post, though the log entry is "green" (OK). Also, the results from the selection for customizing-layer and configuration-layer are identical (the screenshot only shows my selection for conf layer, but I tried cust before that and got the same result):


From this log I can't really see, what's going wrong. This rather looks like an initial check of the target mapping from the launchpad upon opening the launchpad itself to me, which seems to succeed.

Do you happen to know whether there are other analysis-possibilities than those I already mentioned in my opening post?

Cheers, Lukas


Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi, Lukas.

The tools available are really just those outlined here. So it might be good to run through those just to see if anything stands out. Also, the development team has put together a Note with recommendations for troubleshooting here:

2116090 - UI Addon, SAP_UI: Information for customers for efficient incident analysis

Since you're getting results in FLIA when restricting to assigned roles then it doesn't appear to be an issue with authorization. It's likely either a cache issue or another scenario we haven't run into yet. If you rule out the cache as mentioned in the Note above and it still persists, you could always verify that the app is not under the Inactive Applications folder, as detailed in KBA 2348738.

Past that it doesn't seem like something that's going to be solved so simply here. You might consider opening an incident.

Thanks,

Keith

0

Hi Keith,

thanks a lot once more! The help link and the note you outlined contained some information I did not have yet, i.e. /UI2/LOG and user-side "cache-killers", maybe those will do the trick. If they don't, I'll open a customer incident.

Cheers, Lukas


EDIT: These new analysis approaches unfortunately didn't help either, so I'm raising a ticket on "low" (since I do have a workaround) and will let you know if the SAP Support can sort out what's going wrong.

1