Skip to Content
avatar image
Former Member

Still no data in Excel InPlace

Hi.

No data is being displayed when I use the Excel view in an ALV from 'REUSE_ALV_GRID_DISPLAY', but this is not the usual problem.

I have the recommended settings in Excel in Tools > Macro > Security.

The View tab of Change Layout in the ALV lists the templates sap_om.xls and sap_mm.xls.

Trying Excel InPlace for different users and different PCs seems to show that the problem lies with the PC and not the user.

I have re-installed Excel and SAPgui on my PC, but the fault remains.

My SAPgui is 6.20 patch level 42.

My Excel is 2002 SP-2.

What could be the problem?

Thanks,

John

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • avatar image
    Former Member
    Jan 25, 2007 at 04:18 PM

    alternate way is add a pushbutton in the menu and when user clicks on this...use GUI_DOWNLOAD functionality and download the internal table contents to Excel file.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 25, 2007 at 04:58 PM

    Thanks, Ramesh, but we could not really do that for every report or transaction that uses Excel InPlace.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 28, 2007 at 10:22 AM

    Just wondering, when you say you 'have the recommended settings in Excel in Tools > Macro > Security', did you tick the 'Trust Access to Visual Basic Project' under the Trusted Sources tab in Excel in Tools > Macro > Security'?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 28, 2007 at 11:35 AM

    Hi John,

    is there any reason not to use <b>SAPGUI 640 level 22</b>?

    Regards,

    Clemens

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 29, 2007 at 09:19 AM

    Thanks for the above responses.

    Yes, I have ticked 'Trust Access to Visual Basic Project' under the Trusted Sources tab in Excel in Tools > Macro > Security', and I have set the Security Level to Medium. I also tried Low without success.

    The SAP notes mentioned do not seem to address my problem.

    There must be a chance that upgrading to SAPgui 640 level 22 as suggested could fix the problem. However we have PCs with same same SAPgui (620 patch level 42), some of which have the Excel InPlace fault and some of which do not.

    John

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi!

      I'ts an another excel setting. In excel XP set this:

      Tools > Macro > Security - Trusted publishers tab, click on the Visual basic project is trusted (something like that) checkbox.

      Regards

      Tamá

  • avatar image
    Former Member
    Oct 19, 2007 at 11:09 AM

    I have a possible answer to my own question.

    I have re-installed my Kaspersky Anti-Virus for Windows Workstations software.

    It is now version 5.0.712. I don't know what it was before.

    Now when I try to use Excel InPlace, I get a Kaspersky dialog box four times, warning about a potentially dangerous macro, and advising me not to execute it. If I allow the execution of each macro, then Excel InPlace works.

    So it seems possible that Excel InPlace was not working before because my anti-virus software was silently preventing the execution of the macros.

    Can anyone confirm that this can happen?

    Thanks,

    John

    Add comment
    10|10000 characters needed characters exceeded