Skip to Content
0

Design Studio Editor placeholder issue when in SAPUI5 m mode

May 09, 2017 at 01:38 PM

106

avatar image

Hi

I've encountered a strange issue when using DS editor in m mode.

I had a standard blank template app that i migrated to SAPUI5 M mode. When i navigate around the build in the editor, the positioning of the placeholders is not aligned to the actual object it refers to.

Example

The only way to get the placeholder over the object is to modify the settings, such as change the position, or edit the object text etc.

This then puts the placeholder over the object. ALL other objects are still out of alignment. And if I navigate away from the page to another one and come back, it out of position again.

When I'm in "non M " mode, I don't have any issues

What have I tried so far?

1. Tried adjusting screen resolution. This has no impact, I have tried on my laptop screen, and 2 different types of monitor, they all behave the same.

2. I upgraded DS from 16.1.1 to 16.4.2 - No difference (apart from a few more m design options)

3. I thought there may have been some corruption in the migration process, so I decided to create a simple NEW app using the basic M template. After nesting a grid layout, in a panel, and adding a sub panel, i was quickly able to replicate the issue.

4. Trawled through Google, SCN and can't find anyone else with the same issue.

Any thoughts would be appreciated.

Cheers

Mark

10 |10000 characters needed characters left characters exceeded

Hi Mark - what are your objects? Are they panels, grids, or?

0

Hi Tammy

The objects could be anything, they are all out of alignment

So far I am building the shell of the application, so it only contains

Panels, Pagebooks, GridLayouts, Text boxes

The biggest frustration is that none of this occurs in the SAPUI5 mode, only when editing "m" apps.

In my "clean" test where I started with a blank canvas, I had no CSS other than the standard, but it still occured.

Regards

Mark

0

Ooops, submitted an "answer" and not a comment, let me try again here :) :

Can you share an export of the .biapp file?

0

Hi Mike,

In order to establish if the problem was local to my PC, i decided to install DS 16.4.2 (Win 64) on a virgin PC that has no SAP or Eclipse on it.

I then created this mini app and was able to demonstrate the same issue, so at least I know it's not my PC.

I exported the whole app, but could not attach the .zip file, so have added ".txt" at the end of each file

Thanks to you both for taking time out looking at this. I'm new to DS and have spent a lot of time reading your and Tammy's contributions to the community.

Many thanks

Mark

Files attached

basic-layout-sapui5mcss.txt

contentbiapp.txt

exportproperties.txt

0

Happy to try to help!

I was able to bring in your app, however I may not be following your issue exactly, because I'm unable to reproduce the issue:

See below, am I missing something perhaps?

mark.png (126.9 kB)
0

Hi Mike

The issue is hard to explain, so i taken a quick screengrab video using the same DS app that you loaded.

See http://screencast-o-matic.com/watch/cbhQYPXtiE

Please let me know if you can't see it.

I am on the latest version of DS 16.4.2 64bit

Regards

Mark

0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Mike Howles
May 09, 2017 at 09:14 PM
0

Ah, ok I got it. I didn't notice the Page Book. That's the issue. The sliding animation is messing with the canvas at design time. I've noticed that you can actually just slightly resize your DS window or any DS panel (like the dividing section between canvas and property panel) and it will "snap" the canvas back into commission.

This seems like a new bug to me, however I can't be sure, as I do not like the Page Book component that much. I thought that there was a way to turn off the "slide" transition but perhaps that was only available in "commons" mode or I am just going crazy.

Nevertheless, I'm pretty sure your issue is due to the Page Book sliding the page and the canvas not "waiting" to update the position placeholders until the page slide has completed. As a workaround during design time, you could simply slightly resize your DS window to knock it back into order if that makes sense?

EDIT: I'm probably still crazy for other reasons :) but I confirmed there's control over transition in commons mode only:


mark2.png (16.6 kB)
Show 3 Share
10 |10000 characters needed characters left characters exceeded

Ok, that makes sense. Yes i noticed that in 'm' mode that the transition effects has gone, but I didn't join the dots.

So i guess i will raise this with SAP then.

Out of interest, what would you use instead of the pagebook? Do you just use panels and show/hide the ones you want to work with?

The dashboard I've been tasked to create has a number of different types of data that they want to present, so the pagebook is a good way of handling that, well at least it was before i migrated :-)

Thanks agian for your help here.

Regards

Mark

0

Hi Mike,

How do I mark your response as an Answer? Sorry, bit new to this.

0

I had to convert it to an answer on my end.

0