/scripts/ahub.form.attachments.js
0

Standard EAM List reports - Long runtime first (initial) execution ...

May 09, 2017 at 11:56 AM

54

avatar image

Hello experts

We've experienced a great difference in a 'first' execution on SAP Standard EAM Reports such as the "Order Operation List" or "Equipment List", both in Dialog or Dark-mode ...

This is evident / unlucky when we're using these reports or derived functions of these in background Processing or Services.

Suppose we call some Standard Report (say Trx. "IW49N") in Background with a Selection-variant via RFC or Batchjob, the first time we call the report takes up a loooong time. When executing it the second time, the response time is much better with the same Variant.

Is this merely a "Buffering" issue? How to get the 'initial' execution to be as close to a preceding call in terms of Performance? I haven't found any hint on this (SAP-KBA?) ...

I will be doing all kinds of monitoring / tracing, however an immediate hint / clue is much appreciated. If nothing substancial can be found, should we try to get around this via some kind of Dummy Call / Initial Call ...? Any experiences on such phenomenon?


Thanks in advance

Nic T.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Peter Atkin May 09, 2017 at 12:08 PM
0

Nic,

Talk to your ABAP/Basis team who should be able investigate the issue.

PeteA

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks for the suggestion Pete. Will do ...

0
Skip to Content