Skip to Content
author's profile photo Former Member
Former Member

Need help with a Role Authorization

I am having trouble assigning a role to a user.The role for transaction MC.A was assigned to the user in the production client. The user can access the transaction but when they select the parameters and execute the following error comes up,

Authorization Check:Scope of selection 'Plant' was restricted.

The Plant they selected was 1000.

So then i went into PFCG>Authorisations>Change Authorisation Data>Logistics Controlling and then i selected the node which had Plant.

From there(i can't remember the step i did right now) i assigned an ' * ' to the Name of the information Structure,and generated that node. All this was done in development and then trasported to Production and i'm still getting that error with the Authorization check above. Could someone please advise me what direction i should be heading in.

Bottom line the user has access to the transaction but cannot execute when the selection parameters are chosen you get that error!!!

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 25, 2007 at 03:38 AM

    Hi,

    I think the user does not have authorization for this plant 1000.

    After they had execute the tansaction MC.A, execute SU53 to find what are the authorizations available for that user.

    Is they do not have authorization to see any plant details, request the Security people in Basis to assign proper authorization object to the user.

    Regards

    Subramanian

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      I did the SU53 when the error occured(i.e with the user's login in production) and i got the following message

      The following authorisation object was checked

      Object M_IS_PART LIS Standard Analysis:Info Structure/Division

      Object Class LC Logistics Controlling

      Field Value

      Name of Information Structure

      S039

      Division

      01

      So i went back into the PFCG ( In production)and generated that node with information structure S039 but still it presents that error when i tried to the transaction.

      I went back to development and generated it and when i logged back into production and executed the transaction ,still the same authorization check problem! Oh this role is also assigned to other users approx 7 in total and with their "log in's' you're still getting the same error.

  • author's profile photo Former Member
    Former Member
    Posted on Jan 25, 2007 at 05:09 AM

    there seems to be some authorization problem for this user for plant 1000. Check in production whether the user role has access to this plant. if not, regenarate the request in development and move the same to production.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.