Skip to Content
author's profile photo Former Member
Former Member

Master data extractor

hi gurus

i have an issue with the master data extractor material text. i am extracting the data from 0material_text data source to the respective infoobject in the BW. we also maintaining the delta upload daily.

problem what i encounter is,There are some records with out material description in the BW in some earlier delta load. when i tried to debug the extractor with the same set of records in RSA3 it shows the description for material. i couldn't figure it out what is the reason for some material numbers its not pulling the text data where as i can see it in the RSA3.

can any one spell beens so that i will work around .

Thanks

Roopa

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Posted on Jan 23, 2007 at 08:36 PM

    Hi Roopa:

    How many records do you have for your material attr?

    are you saying that you were not able see the mat desc in PSA too?

    My best bet is there might be a load error on text and you missed some records. Check on that too..

    assign points if helpful

    kalyan

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 23, 2007 at 08:57 PM

    Hi Kalyan

    we are sending data directly to data target and we have around 1 million records in the production .As i said earlier there is no failure in delta loads of material text. some of the around 6 records are missing data for material text where as i could see it in the RSA3. plz don't say that once again run the full load and make it init .

    i need to figure out where exactly the problem is with respect to delta load in the extractor.

    Thnaks

    Roopa

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Roopa -

      Since you've already identified the missing texts, why dont you go ahead and do a selective full load to fix them. You dont have to re-initialize the delta for this. But as for your question as to why the texts are missing...it could be many factors like blank record overwriting the existing texts in BW...We had a similar issue with 0BPARTNER loads from CRM.

      Since you are saying that there are no failed delta loads (which might have been the obvious culprit)...try to search the SAP Notes if any other clients experienced this issue. If not, you may have to do more analysis to understand the root cause. But to fix this issue, go aead with a selective full load...

      Good luck!

  • author's profile photo Former Member
    Former Member
    Posted on Jan 30, 2007 at 01:16 AM

    Hello Guru's

    i loaded the missing material text description records in the BW. after three deltas again there are some missing material texts. so debugged the extractor and it gets the data fine for those missing material records . i want to know why extractor is behaving like this occasionally.

    if you have any thoughts on this. plz let me know so that i will work on it.

    Thanks

    roopa

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.