Skip to Content
0

Sub reports don't work in SAP Crystal Report 13.0.20, 13.0.19, and 13.0.18 for Visual Studio

May 08 at 06:53 PM

117

avatar image

Hi Everyone,

We use SAP Crystal Reports for Visual Studio (WPF).

After I upgraded SAP CR from SP17 to SP20 (32 bit), we realized that Sub Reports do not work anymore: If you click on a blue link for Sub Report then nothing happens. It used to open Sub Report in a new window.

I tested this feature in SP19 ans SP18 as well and can confirm that Sub Reports don't work there too. So I had to downgrade back to SP17 so far.

There is also another issue in SP17-SP20. For those sub-report links, even if you say align the link-text to the right, it always aligns left.

Please let me know if those are known issues and if they will be fixed soon?

capture.jpg (61.6 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Don Williams SAP Employee Moderator May 24 at 08:10 PM
0

We are aware if the issue. Are the subreports on Demand? If they are change them to not be and it will work.

Seems to be an issue in the DB connection properties are not being used.

Incident 156727- KBA - 2456246

Don

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Don, please let me know what is estimated release date for this bug fix?

Thanks,

Vasya

0
Eldar Mulic May 24 at 08:08 PM
0

We have the same exact problem! This is a huge issue for us too! Same thing happened, we upgraded to SP 20 and noticed this problem.

Have to rollback to SP17 because of this, but we wanted some other bugfixes from the versions in between.

Please, can someone on SAP side look at this ASAP?

Thanks,

Eldar

Share
10 |10000 characters needed characters left characters exceeded
Don Williams SAP Employee Moderator Aug 09 at 09:33 PM
0

Should be end of this month, August, if all goes well. I tested this with SP 21 beta and it is working again.

Don

Share
10 |10000 characters needed characters left characters exceeded