Skip to Content
0

Agentry File Download from Network Share

May 08, 2017 at 03:16 PM

37

avatar image
Former Member

I have an Agentry project configured to download a file from the SMP server which is working successfully. However when I try to download a file from a network drive, Agentry simply goes right through the Step command and does not download the file.

I have tried a number of unsuccessful configuration and permissioning setups.

Currently, my step is the following which works:

TYPE "D:\MobileData\Geodatabase.zip"

I have tried the following which do not work:

TYPE "Y:\MobileData\Geodatabase.zip" (note: Y:\ is a network drive)

TYPE "\\ServerName\MobileData\Geodatabase.zip"

When I copy either of the above to TYPE commands into the command prompt it works so I do not think it is an issue with the actual command. I have given permission on these shared drives to everyone as well as the service name running SMP.

Any ideas as to why this does not work?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Bill Froelich
May 09, 2017 at 01:46 AM
0

If your SMP server is running as a service then it doesn't have access to your user drive mappings. Have you tried running the SMP server under your user account (go.bat) instead of as a service to see if the files will download correctly?

That would be the first thing I would try to confirm if it is an account issue or not.

--Bill

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

I will try, but I have specified the server name directly instead of the user mappings and that did not work. I have also confirmed that the server folder is accessible by everyone.

0