Skip to Content
avatar image
Former Member

How to add values to the Regional Market Field KNA1-RPMKT in BP customer master general tab

Dear Friends,

It's been a while I posted query here- So here it is...

For regional market field (KNA1-RPMKT) in customer master: general data tab, by default the field was not used and we enable it through function module. However, this is not in configuration level to add values either.

My question is-

- at first instance why this field in grey out by SAP as default?

- Since I enable it through function module and how can I add values (entries were - 800 to be added) into this field?

Your Immediate respond is highly appreciated.

Thanks,
Satish

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    May 08, 2017 at 08:42 PM

    If you look in SE11 at the domain definition for RPMKR you'll see there is no Value Table assigned to it. Therefore you will not find any configurable options to add values to this field. Because there is no table to store such values.

    If a field is labeled as "not in use" by SAP it does not necessarily mean it's free to use for the customers. There are other designated fields in the customer master that are customizable, pick one of those instead. Or add a custom field.

    Add comment
    10|10000 characters needed characters exceeded

    • No, that's not exactly what I said. The value table must be assigned in the domain so that the field values could be customizable in SPRO. The field description in the dictionary is completely irrelevant. I cannot possibly know why SAP entered such description or what the field's purpose is or was. What I was pointing out is that even when a standard field is labeled "not in use" it does not mean it's OK for the customers to start using it.

      As I said, the customers should stick with the fields customizable in SPRO or add custom fields, when needed. It's a common knowledge in SAP and has been a usual practice for many years already. Not sure why you felt otherwise.

  • May 08, 2017 at 12:39 PM

    If it was a typo error and you intend to say RPMKR, then the option is very much is available to set optional or mandatory through configuration.

    Add comment
    10|10000 characters needed characters exceeded

  • May 10, 2017 at 11:58 AM

    There are very few objects in SAP which have spare fields for free usage. All fields have usually a meaning and a dedicated coding behind. Some fields had their big time back in R/2 times, for some was the coding removed but the field was left in the tables to allow customers to keep their Z-programs unchanged, and probably SAP itself did not want to adjust their countless programs that have a reference to this table.

    If you are in need of a field then make use of a modification free solution: Use the classification system!

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 08, 2017 at 01:56 PM
    -1

    Thanks , yes it's suppose to be KNA1-RPMKR.

    Well I have changed the field to display entry in the field group. However, I would like to know how to add values to the field?

    In configuration ->S&D->

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 08, 2017 at 01:58 PM
    -1

    In configuration ->SD->Master Data->Customers->marketing->Define classficiation, Nielsen ID, Customer classification, Industry Secor codes, legal statuses. These are the only options I can see. Do you think is there any other place that I can do this configuration for adding values to the field?

    Regards,
    Satish

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 10, 2017 at 11:37 AM

    Yep, I agree the creation of custom table into config is the only option we have for this at this point. Anyways I am marking this question as answered and still it's unknown to the customers why this field cannot be used/allowed by SAP

    Thanks for your time

    Until next time

    Satish

    Add comment
    10|10000 characters needed characters exceeded