Skip to Content
0

Error in Fiori Factsheet - no System alias found

May 08, 2017 at 07:58 AM

306

avatar image

Dear Experts,

I want to use the Fiori Factsheet for Sales Quotations but no data is shown after I navigated to a quotation from the search results.


The browser console as well as the Gateway-Log of Fiori-Frontend-Server shows the following error message that implies that the ODATA-Service ZCB_SALES_QUOTATION has no System-Alias.

When I check the system alias assignment for the service in /IWFND/MAINT_SERVICE or in ODATA-Customizing (SPRO), there is an existing system alias entry.

The system alias is defined like this:

Other apps, for example transactional apps "my quotations" are working fine, only factsheets are affected.

I checked the required Back- and Frontend-Components in the Fiori Library for the Factsheet which are required, the odata-services, the ESH-setup, SAP notes in OSS - I cannot find any misconfiguration.

Maybe you have some suggestions in this case what might be missing?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Mark von Wilmowsky May 08, 2017 at 03:06 PM
0

I found a workaround to get the factsheets running.

After navigating on the searchresults, Fiori Launchpad passes a parameter in URL named sap-system:

If I remove this part or replace the value with my actual System Alias (FIORI_SCE), the factsheet works fine.

Any ideas, why and how Fiori launchpad resolves this parameter?


Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Mark,

How about adding SID and client in the FIORI_SCE system alias?

Regards,

Masa

0

Yes, enhancing the system alias with SID and client helps calling the factsheets correctly - thanks for that input!

This is quite confusing, because other apps using this alias without SID and client were working fine.

0