Skip to Content
author's profile photo Former Member
Former Member

SSL connection between ADS and EP trial

Hi,

I have installed Enterprise portal full java edition (trial version) in a Windows XP machine. I have also successfully configured ADS for user authentication with EP (Netweaver 2004s SP9 version). Now, the requirement is to have a writeable connection with the Active Directory Server so that users in EP can modify their credentials on ADS. Is a SSL connection between EP 6.4 and ADS absolutely necessary for this? Also I need to know if the trial version supports SSL or not. Whenever I am choosing dataSourceConfigurations_ads_writeable_db.xml from the configtool, and check the SSL checkbox, the "Test Connection" and "Test Authentication" button is greying out.

The WebAS version is 7.0 and I have configured Visual admin to start ssl and keystore service.

Points are guaranteed on good answers.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jan 19, 2007 at 06:12 PM

    Hi Subhabrata Mukhuti,

    You could change the user's information accessing the "User Administration >> Identity Management". The user, that you configured at UME Configuration[1], must have the Administration Domain permission at the LDAP Server. After that you are able to change the LDAP information using the Portal.

    If you are using the Microsoft Active Directory as LDAP server you only be able to change the password if the connection between the Portal and LDAP Server is under SSL.

    [1] - Configuring UME to Use an LDAP Server as Data Source

    http://help.sap.com/saphelp_nw04/helpdata/en/cc/cdd93f130f9115e10000000a155106/frameset.htm

    I hope this help,

    Alcides Flach

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks for the answer Alcides. It is helpful, but I also need to know specifically <i>if Netweaver 2004s SP9 Full Java <u>Trial version</u> supports SSL or not</i>.

      I have already created a domain user in AD with permission in all branches of the ADS. I am using this user to connect to the ADS from Visual Administrator. It is working fine with a read-only connection through port 389. But whenever I am changing over to a writeable connection and checking SSL, the options for "Test Connection" and "Test Authentication are greying out.

      I have tested with a writeable connection without SSL- it is allowing users to be created in the portal, but when I logoff and then log back in, the users are nowhere to be seen!

      I am following the instruction from help.sap.com. It advices to change the connection settings from Visual Administrator and not from System Configuration-> UM Configuration.

      Can someone please help me?

  • author's profile photo Former Member
    Former Member
    Posted on Mar 01, 2009 at 11:29 AM

    It was successful with EP trial.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.