$(function () { pageContext.i18n.modTalk = 'moderation talk'; pageContext.i18n.replyToComment = 'Reply'; pageContext.i18n.modTalkEmpty = 'moderation talk is empty'; pageContext.url.getModTalk = "/comments/%25ID%25/listModTalk.json"; pageContext.url.possibleCommentRecipients = "/comments/%ID%/possibleRecipients.json"; pageContext.url.commentEdit = '/comments/%25ID%25/edit.html'; pageContext.url.commentView = '/comments/%ID%/view.html'; pageContext.i18n.commentVisibility = { 'full': 'Viewable by all users', 'op': 'Viewable by the original poster', 'mod': 'Viewable by moderators', 'opAndMod': 'Viewable by moderators and the original poster', 'other': 'Advanced visibility', 'dialogTitle': 'Comment visibility', 'selectGroups': 'Visible to groups', 'selectOther': 'Other recipients', 'selectOriginalPoster': 'Original poster', 'selectModerators': 'Moderators', 'selectAssignees': 'Asked to answer users' }; pageContext.i18n.commentMenuLabels = { 'comment-edit': 'comments.menu.edit', 'comment-delete': 'comments.menu.delete', 'comment-convert': 'comments.menu.convert' };pageContext.i18n.answer= { bestAnswer: 'Best Answer', controlBar : { accept: 'Accept', unaccept: 'Unaccept', acceptCommand: 'Accept this answer as correct', cancelAcceptedCommand: 'Remove this answers accepted status' } }; window.croles = { u: false, op: false, m: false, og: false, as: false, ag: false, dc: false, doc: false, eo: false, ea: false }; tools.init({ q: { e: false, ew: false, eo: false, r: false, ro: false, d: false, dow: false, fv: false, c: false, co: false, p: false, tm: false , ms: false, mos: false }, n: { f: false, vf: false, vfo: false, vr: false, vro: false, c: false, co: false, vu: false, vd: false, w: false, wo: false, l: false }, c: { e: false, eo: false, d: false, dow: false, ta: false, tao: false, l: false }, a: { e: false, ew: false, eo: false, d: false, dow: false, a: false, aoq: false, ao: false, tc: false, tco: false, p: false, tm: false }, pc: croles }, { tc: true, nsc: true }); commandUtils.initializeLabels(); }); Skip to Content
avatar image
Former Member

Restful url error - "reference" parameter with ":" or "-" characters

Hello,

When the Restful URL contains the character ":" or the character "-", the response is Error 400 ...

For example, this URL doesn't work :

http://boserver:6405/biprws/raylight/v1/documents/104501/reports/5/map?reference=5.A.-

But reference contains the character ":" or the character "-" :

<node name="0073" reference="5.A.x"/>
<node name="0074" reference="5.A.y"/>
<node name="0076" reference="5.A.z"/>
<node name="0077" reference="5.A.:"/>
<node name="0079" reference="5.A.-"/>

<node name="0080" reference="5.A.10"/>
<node name="0081" reference="5.A.11"/>
<node name="0082" reference="5.A.12"/>

How to pass these special characters in the URL ?

Thank you.

Best Regards,

Antoine

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    May 16, 2017 at 06:02 PM

    Has anyone ever had the problem ?
    Thank you for your help !

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 02, 2017 at 06:44 PM

    Hi Antoine,

    Can you confirm if you still have the problem when URL encoding the characters like ":" and "-" ?

    Dan

    Add comment
    10|10000 characters needed characters exceeded