Skip to Content

How can "noDocument" be implemented in an openDocument call from a Design Studio App to Webi report?

I have a simple openDocument call that is activated from a button click event in a Design Studio application. The openDocument URL is as follows:

http://<server
name>/OpenDocument/opendoc/openDocument.jsp?iDocID=AYWCufG2eENPgBvE.cYRVfw&sIDType=CUID&sType=WID&lsSPARAM_1:=male&lsSPARAM_2:=20&noDocument=true

The targeted webi report is reached but fails to open with the below error:

The openDoc call works fine without the "noDocument" parameter appended. However, a requirement is that the Webi report be opened in 'design mode.' Do I need to add additional parameters for "noDocument" to work correctly OR is there another option for opening Webi reports in 'design mode?'

Environment: SAP BusinessObjects 4.1 SP7 Patch 3, Design Studio 1.6

opendocerror.png (8.9 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • May 05, 2017 at 08:02 AM

    Hi You can write below script on button on select

    Application.opennewwindow ("http://<server name>/OpenDocument/opendoc/openDocument.jsp?iDocID=AYWCufG2eENPgBvE.cYRVfw&sIDType=CUID&sType=WID&lsSPARAM_1:=male&lsSPARAM_2:=20&noDocument=true");

    Also ensure your Design studio and Webi reports have enough authorisations to placed them in relevant folders in BI launch pad.

    BR,

    Lakshmikanth

    Add comment
    10|10000 characters needed characters exceeded

    • Lakshmikanth, thanks for your response.

      I know the proper syntax for passing a URL to a new window in Design Studio. My issue is with the openDocument call. Specifically the "noDocument" parameter.

      When this parameter is appended, I get the above mentioned error. When it is not included, the Webi report opens without issue.

      Thanks.

      -Tyrone