Skip to Content
author's profile photo Former Member
Former Member

SM59 - Type G connection failure - ICM_HTTP_CONNECTION_FAILED

I need to setup an SSL communication to a third party.

The HTTPS port 8443 has been configured for this

If I use function module HTTP_POST with a URL

e.g https://test.support.example.com/post/CreditCardAPIReceiver

I can correctly connect and get a response back.

If I try and create an SM59 destination.

Connection type G

Host = test.support.example.com

path = post/CreditCardAPIReceiver

service = 8443

I have tried all combinations for security options:

SSL Inactive/active and with standard client and annonymous

When testing the connection I get ICM_HTTP_CONNECTION_FAILED.

has anybody got any ideas what i'm doing wrong.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 16, 2007 at 12:47 AM

    See if this helps.

    registering-rfc-destination-fails-in-sm59

    - Guru

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 16, 2007 at 05:26 AM

    since this is https you have install the certificate in your ABAP system. check this weblog for complete details.

    <a href="/people/thomas.jung3/blog/2004/11/17/bsp-a-developers-journal-part-xiv--consuming-webservices-with-abap">Consuming WebServices with ABAP</a>

    Regards

    Raja

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 16, 2007 at 05:56 AM

    Thanks for you response Raja.

    The third party we are connecting to has a TEST environment which doesn't require a digital certificate authentication. This is initially what I'm trying to connect through via SM59. So I'm still posting to a HTTPS:// but there is no digital certificate.

    I can post and get a response from the same URL when using HTTP_POST and specifiying URL.

    However if I try and create the same information in SM59 and either test the connection or use cl_http_client=>create_by_destination to post a request I cannot connect to there server.

    I've also tried connecting to there Production environment which does require a digital certifcate. I've loaded the digital certificates into the Anonymous client but still cannot connect when testing the connection in SM59.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.