Skip to Content

500 Internal Server Error accessing DTR

Dears,

after a frest installation on WIndows 2008 R2/ASE 16 trying to access the DTR url we recive:

"500 Internal Server Error"

Into the default trace we found:

"

Global [startApp] operation of application [sap.com/tc~dtr~enterpriseapp] finished with non-critical warnings for [809] ms on server process [4170850]: [

>>> Warnings <<<

1). com.sap.ASJ.web.000607 (Failed in component: sap.com/tc~dtr~enterpriseapp, BC-CTS-DTR-SRV) Initialization of servlet [DTRServlet] failed. Check init() method of servlet. Error is: [javax.servlet.ServletException: WebdavServlet.init() failed : com.tssap.dtr.pvc.repository.InitializationException: Getting an instance of com.tssap.dtr.pvc.util.sql.GenericSQLClassFactory is not allowed because the DB platform is not yet initialized. Make sure that the initialize method is called before getting an instalce of this class.]]#"

What could be the problem ? There are no Oss Notes on this

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    May 04, 2017 at 11:51 AM

    Hello Roberto,

    Could you please let me know the Release the SP and the patch level of your component "DI DESIGN TIME REPOSITORY".

    This kind of error usually occurs if Sybase platform is used.

    Please let me know the exact version.

    Best Regards,
    Szabolcs

    Add comment
    10|10000 characters needed characters exceeded

  • May 08, 2017 at 07:35 AM

    Thanks, infact I already solved using deploy via telnet

    Now it works.

    regards

    Add comment
    10|10000 characters needed characters exceeded

  • May 04, 2017 at 12:45 PM

    probably you haven't initialized your nwdi.

    Add comment
    10|10000 characters needed characters exceeded

  • May 04, 2017 at 03:20 PM

    Hi thanks for the feedback.

    I found note 1650822 , it matches my case. The error in default traceis the same.

    My JDBC driver it's ok I have

    jConnect (TM) for JDBC(TM)/16.0 SP02 PL05 (Build 27308)/P/EBF26574/JDK 1.6.0/jdbcmain/OPT/Wed Sep 21 19:02:16 PDT 2016,

    since I'm using ASE16

    But the DI-DTR component is low : 7.30.0.0., according the note I should have at least Sp04

    THis is an het system copy from another system, running on Linux/Oracle. On the source system the NWDI works perfectly with the actual component versions.

    But the problem is that It seems I can't update only the DI-DTR component, the SUM reject it with the msg:

    "002 Componente DI-DTR cannot teh updated to higher level,

    005 component DI-DTR is part of SAP Stack definition file"

    THe JSPM does not work anymore on this release. I cannot upgrade all the components of the J2EE instance, it is not foresee. I need only to make the DTR and the others DI components on the target system .

    How I can patch only the DI-DTR component ?

    regards





    Add comment
    10|10000 characters needed characters exceeded

  • May 04, 2017 at 03:28 PM

    Addendum:

    I tryied 'Manually Prepared directory' with the DI-DTR patch sp04 or Sp07 coming from the Oss NOte , but the SUM 19 always stops rejecting the patch.

    Add comment
    10|10000 characters needed characters exceeded

  • May 05, 2017 at 12:05 PM

    Hi Roberto,

    You can patch only one component if you use telnet. Please note that ALL SP level has to be the same on your system.

    Best Regards,
    Szabolcs

    Add comment
    10|10000 characters needed characters exceeded