Skip to Content
0

Idle session timeout on S/4 HANA 1610 FP01 regardless of the parameter.

May 04, 2017 at 07:12 AM

509

avatar image

Hello Experts,

Our S/4 Hana Server keeps timing out idle sessions after few minutes even though we don't have the parameter rdisp/gui_auto_logout set in any profile.

We tried setting it to something like 60m or 9999 but it still times us out if we stay idle anyway.

Kindly Assist.

Best Regards,

Ashraf

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Bartosz Jarkowski May 04, 2017 at 08:41 AM
0

There is many reasons why your idle session is being dropped. Could you please paste a print screen of the message you're getting when the connection is dropped?

You can also try to play around with following parameter:

rdisp/keepalive_timeout

Best regards

Bartosz

Show 5 Share
10 |10000 characters needed characters left characters exceeded

I tried setting the parameter you mentioned to 3600, still times me out of i stay idle for a bit.

capture.png (17.9 kB)
0

Hi,

the attached screen clearly says it's not the auto logout functionality.

You can try also with setting the following parameter to some small value (let's say 20):

rdisp/keepalive

This parameter is sending ICMP package to your GUI session, so it may trick your firewall / router.

Best regards

Bartosz

1

Hello,

My OS firewall is turned off and my ports are open, not sure what is causing this.

I'll try editing the parameter you mentioned and see if it helps.

BR,

Ashraf

0

It can be a network device - I encountered similar issues many times, when router was killing idle connections.

Let us know if the parameter change helped :)

Best regards

Bartosz

0

rdisp/keepalive was indeed the problem, changed it to 20 and i am not getting anymore timeouts.

Thanks a lot for the help.

0
Juan Reyes
May 04, 2017 at 09:07 AM
0

Hi Ashraf,

If you want to disable GUI timeouts you should set the value of rdisp/gui_auto_logout to 0, this parameter is dynamic so you can change it in RZ11 without restarting the system.

Value of this parameter is in seconds so 60m isn't a valid entry.

Regards, JP

Show 4 Share
10 |10000 characters needed characters left characters exceeded

I have both parameters on 3600 at the moment, shouldn't that be 1 hour?

0

That's correct, if the system is kicking you out before then, please post error message shown and also SM21 error.

Regards, JP

0

Dear Juan,

I have included a screenshot if the error 2 posts above.

Here is the SM21 log

Best Regards,

Ashraf

capture.png (39.6 kB)
0

Hi Ashraf,

Check the respective work process developer trace for errors and post them here.

Regards, JP

0