Skip to Content
avatar image
Former Member

Unable to Connect with SAP

Hi,

I try to work with the exchangeProfile, and I get this error:

Connect to SAP gateway failed Connect_PM  TYPE=A ASHOST=vtoxde SYSNR=00 GWHOST=vtoxde GWSERV=sapgw00 
PCS=1 LOCATION    CPIC (TCP/IP) on local host with Unicode ERROR       max no of 100 conversations 
exceeded TIME   Thu Jan 11 12:10:56 2007 RELEASE     700 COMPONENT  CPIC (TCP/IP) with 
Unicode VERSION     3 RC          466 MODULE      
r3cpic_mt.c LINE        10713 COUNTER     3

I'm working with PI.

Any idea?

Regarts.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 11, 2007 at 06:27 PM

    looks like maximum number of connections are exceeded. Check if you can restart SAP.

    --Archana

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 11, 2007 at 06:30 PM

    Hi ,

    please ensure, that the gateway TCP port is available in the %WINDIR%\system32\drivers\etc\services file, for example "sapgw44<TAB>3344/tcp"

    or

    /etc/services if it is unix

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 11, 2007 at 07:32 PM

    Hi,

    check out the SMGW transactions and check the gateway service etc is correct/

    Rgds,

    Moorthy

    Message was edited by:

    Krishna Moorthy P

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 11, 2007 at 09:33 PM

    The TCODE: SMGW display:

    vtoxde	jlaunch	vtoxde	sapgw00	xdeadm	Connected	<Java	66203097	Internal Communication	Thu Jan 11 15:29:04 2007	0	0
    vtoxde	jlaunch	vtoxde	sapgw00	xdeadm	Connected	<Java	66212947	Internal Communication	Thu Jan 11 15:23:49 2007	0	0
    vtoxde	jlaunch	vtoxde	sapgw00	xdeadm	Connected	<Java	66208093	Internal Communication	Thu Jan 11 15:28:11 2007	0	0

    I'm working with an AIX Server, and the services file has for ports 3300 and 3001:

    pdrncs           3299/udp                # pdrncs
    ###########      3300-3301      Unauthorized Use by SAP R/3              ######
    mcs-fastmail     3302/tcp                # MCS Fastmail

    A complete reboot was made and nothing happens.

    This is the error:

    Connect to SAP gateway failed Connect_PM TYPE=A ASHOST=vtoxde SYSNR=00 GWHOST=vtoxde GWSERV=sapgw00 PCS=1 LOCATION CPIC (TCP/IP) on local host with Unicode ERROR max no of 100 conversations exceeded TIME Thu Jan 11 15:45:43 2007 RELEASE 700 COMPONENT CPIC (TCP/IP) with Unicode VERSION 3 RC 466 MODULE r3cpic_mt.c LINE 10713 COUNTER 3

    Stack Trace class com.sap.rprof.dbprofiles.DBException:

    Connect_PM TYPE=A ASHOST=vtoxde SYSNR=00 GWHOST=vtoxde GWSERV=sapgw00 PCS=1

    LOCATION CPIC (TCP/IP) on local host with Unicode

    ERROR max no of 100 conversations exceeded

    TIME Thu Jan 11 15:45:43 2007

    RELEASE 700

    COMPONENT CPIC (TCP/IP) with Unicode

    VERSION 3

    RC 466

    MODULE r3cpic_mt.c

    LINE 10713

    COUNTER 3

    at com.sap.mw.jco.MiddlewareJRfc.generateJCoException(MiddlewareJRfc.java(Compiled Code))

    Any ideas?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 31, 2007 at 10:15 PM

    We Reinstall the server.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 27, 2007 at 04:28 PM

    Set the parameter CPIC_MAX_CONV to a nubmer higher than 100 in your .dbenv* files for whichever instance(s) are connecting to your backend system.

    Add comment
    10|10000 characters needed characters exceeded