Skip to Content
author's profile photo Former Member
Former Member

0MAT_PLANT_ATTR delta is not getting changes to Profit Center attribute

Hello,

We are BW 3.1c SP 20 and we have been experiencing a unusual delta problem with 0MAT_PLANT_ATTR datasource from R/3. The delta works just fine but in some cases R/3 is not sending the delta when a profit center got changed. We checked in R/3 and we see that the profit center for that material/plant has been changed but in BW Profit Center attr for 0MAT_PLANT is blank - never came into BW.

Since we are using standard extractor for this delta load, not sure why this is happening. Anybody noticed such problems, any solutions? I appreciate any response on this topic.

PS: R/3 is 4.6c, BW plugin is 2004_1_46C.

Regards

-Bala

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Jan 12, 2007 at 04:09 AM

    Hi Bala,

    The master data extractor would bring in delta only when the base extractor gets changed and not the attribute. Since the 0PROFIT_CTR is just an attribute of 0MAT_PLANT the extractor will not bring in new records when 0PROFIT_CTR gets changed. The extractor will bring in new records only when 0MAT_PLANT gets changed.

    Hope this helps.

    Bye

    Dinesh

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Dinesh,

      When I said delta, I meant to say when a profit center assignment to mat plant is changed in R/3 (when the MARC-PRCTR field is updated/changed for a material). This is in fact a change to the 0MAT_PLANT.

      Regards

      -Bala

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.