Skip to Content
avatar image
Former Member

SAP Resource Adapter

I played a bit with J2EE Server and tried to make a usage of SAPJRA for accessing my RFC/BAPI framework in ABAP server. I can deploy my module but in runtime I get the following error:

java.lang.ClassNotFoundException: com.sap.conn.jco.rt.DefaultJCoRuntime

I tracked the error back into the package sap.comtcbljco_sapj2eeruntime.jar - there is really no such class. Any idea, hint?

Regards

Robert

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Jan 19, 2007 at 12:18 PM

    Hi Robert,

    do you use SAP J2EE Engine 7.10 or any other J2EE Engine? And this exeption occured during your Application was running on SAP J2EE Engine?

    Do you use the SAPJRA provided with that SAP J2EE Engine or have

    you installed it by yourself?

    regards, Eugen

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Eugen

      I was running Sun Java EE 5 SDK engine (Glassfish). On SAP J2EE Engine SAPJRA is running.

      I analyzed this problem deeper and I have seen, that you are speaking about 'JCoRuntime' and that such runtime is currently available only for SAP Java Server Technology. Do you plan to support Java EE JCo Runtimes on non SAP servers (JBoss, Sun, ...) or can I find any documentation/SDK how to adapt standard JCo by myself? My problem is that NetWeaver ist too heavy for my customers and the tasks I am writing, Java EE 5@SAP is not production ready i.e. not accepted by customers and I need SAPJRA. In the meantime I have written my own SAPJCA library but I think it's not the right way. I should spend my time writing the application software, not core libraries.

      Regards

      Robert