Skip to Content
author's profile photo Former Member
Former Member

File(FTP) Adapter doesn't pick any file from FTP server

Hi All,

This is a strange problem. I am trying to pick all the file from a FTP server using File Name: . . But the file adapter doesn't pick any file from the directory. When I change it to a specific file name eg. ABC.txt then it picks up the file ABC.txt only.

My requirement is to pick up all files in the directory and I just do not seem to understand what is wrong. I have used this wildcard option several times earlier and it always worked fine. But in this case, this does not work.

I changed the FTP server to point to an internal FTP server and it works fine.

I have checked all my parameters and everything looks okay. Like I mentioned earlier, if you specify exact file name, it picks up the file.

Any guess as to what is going on here?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

5 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 10, 2007 at 03:57 PM

    Ardent,

    Just try with * and see whether it will picks or not.

    ---Satish

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 10, 2007 at 04:02 PM

    No. * , *.txt, ., ABC*.txt, ABC????.txt nothing works.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Ardent,

      Are you directly picking from the root folder of FTP location? Also are you trying to delete afer picking the file?

      I suggest you just to create one folder and pick the file from that folder. It should work. Its very strange for me also. Just try this out. If not try to check from OS level itself whether it works or not?

      ---Satish

  • author's profile photo Former Member
    Former Member
    Posted on Jan 10, 2007 at 04:39 PM

    No, I am not picking up from the root. I am picking up from a specific folder. I have it as my source directory parameter.

    Like I mentioned, if I give a specific file name, the file adapter picks up that file but if I give * or any variant of it ( ., *.txt etc.), the file adapter doesnt pick anything.

    I tried from command prompt and I am able to download all the files with a wildcard from the FTP server!

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 10, 2007 at 04:54 PM

    Well, the file adapter doesn't pick any file so there is no log. The file adapter keeps polling after the specified interval and comm. channel monitoring says " processing finished successfully. Polling Interval Started". But no message is picked up.

    I checked the log for the messages that were picked up ( because the specified an exact file name). The File is processed successfully thru adapter and integration engine.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      It sounds very strange that you can pick the file up if you write the exact file name, and not when you use the asterisc....

      please, can you provide us with the rest of the parameters of the file adapter, so we can have a closer idea of what is happening.

      bye.

  • author's profile photo Former Member
    Former Member
    Posted on Jan 10, 2007 at 05:11 PM

    Transport Protocol: FTP

    Message Protocol: File

    source directory: /test or test ( <b>either one works</b>)

    file name: * or . or *.txt <b>nothing works</b>

    server: ftp server name

    port: 21

    data connection: passive

    user: ******

    pass: ******

    connect mode: permanently

    transfer mode: text

    QOS: exactly once

    poll: 10 secs

    processing mode: archive ( <b>changed to test and delete as well, but made no difference</b>.)

    archive dir: dir path

    file type: text

    adapter specific attributes:

    checked: set adapter specific attributes

    and file name.

    status: active.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.