Skip to Content
author's profile photo Former Member
Former Member

CTUPARAMS - NOBINPT

We are using Batch Input sessions attempting to run transaction PA30 using the no batch input option. CTUPARAMS - NOBINPT is set to x. but when we process the batch input session from transaction sm35, we get the PA30 screen as if we didn't check the NOBINPT option. fields such as LOGSYS and AWTYP appear at the bottom of the screen. If we record and process the BDC from transaction SHDB and then run it with the "No batch input" option not checked, we get the same reults, so we run it with the option "No batch input" checked and it works. The question is is there a known problem with passing CTUPARAMS - NOBINPT = x to a Batch Input Session?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

5 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jan 09, 2007 at 07:51 PM

    Hi,

    NOBINPT = ‘X’ –This will trick the transaction into simulating online

    mode processing even though you are running in background mode. Some

    transactions behave differently between online and batch modes. This

    could be a work around for an issue you may be having.

    NOBIEND = ‘X’ – This will keep the simulation of an online mode

    processing event after the end of data. This may help if an issue

    arises during processing of a transaction in online vs. batch mode.

    Try to even pass the NOBIEND and check whether it works or not.

    Thanks,

    Suresh Ganti

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      there are several fields that appear on the screen when not using "Not a Batch Input Session" and then the error appears "No batch input data for screen SAPMP50A 1000".

      If we process this same data using transaction SHDB and use the option "Not a Batch Input Session" these fields do not appear and it works. If we process this same data using again transaction SHDB and do not use the option "Not a Batch Input Session" these fields appear and it does not work.

      Some of those fields that appear when not using "Not a Batch Input Session" are as follows.

      PSPAR-LOGSYS

      PSPAR-AWTYP

      PSPAR-AWREF

      PSPAR-AWORG

  • author's profile photo Former Member
    Former Member
    Posted on Jan 10, 2007 at 02:38 PM

    Hi,

    Hi, u have set the CTU_PARAMS-NOBINPT = 'X' . But did u pass the structure to the call transcation statment, bcoz if it is not getting effected means that the structure is not passed with the call transaction.

    Regards,

    Aravind

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 10, 2007 at 04:34 PM

    Hi,

    The use of CTU_PARAMS in BDC is that when recording there are few Options visible before u start recording like mode, No catt, Default like that.

    Take Default for example. it is always checked, the use of it is supose u record a transaction in which it has table control for which u need to write logic. But the number of rows in u'r server may vary from other server when using table control. So in order to avoid that conflict we set default 'X' to get default screen setting.

    Try to go thru SAP Library if possible.

    Regards,

    Aravind.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 11, 2007 at 04:50 AM

    Hi,

    I just checked for transaction PA30. It is working properly with NOBINPT checked. Dude check properly. See the code below and check.

    *****************************************************************************

    data: i_ctu type ctu_params.

    data: i_bdcdata like bdcdata occurs 0 with header line.

    initialization.

    i_ctu-dismode = 'A'.

    i_ctu-updmode = 'S'.

    i_ctu-cattmode = ' '.

    i_ctu-defsize = 'X'.

    i_ctu-nobinpt = 'X'.

    start-of-selection.

    perform bdc_dynpro using 'SAPMP50A' '1100'.

    perform bdc_field using 'BDC_OKCODE'

    '/00'.

    perform bdc_field using 'RP50G-PERNR'

    '1000'.

    perform bdc_field using 'BDC_CURSOR'

    'RP50G-ENDDA'.

    perform bdc_field using 'RP50G-BEGDA'

    '10.01.2004'.

    perform bdc_field using 'RP50G-ENDDA'

    '10.01.2007'.

    perform bdc_field using 'RP50G-CHOIC'

    '0167'.

    perform bdc_dynpro using 'SAPMP50A' '1100'.

    perform bdc_field using 'BDC_OKCODE'

    '/EBCK'.

    perform bdc_field using 'BDC_CURSOR'

    'RP50G-PERNR'.

    call transaction 'PA30' using i_bdcdata

    options from i_ctu.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      I just tried your suggestion

      i_ctu-dismode = 'A'.

      i_ctu-updmode = 'S'.

      i_ctu-cattmode = ' '.

      i_ctu-defsize = 'X'.

      i_ctu-nobinpt = 'X'.

      The following fields are still appearing when attempting to process the BDC session from transaction SM35.

      PSPAR-LOGSYS

      PSPAR-AWTYP

      PSPAR-AWREF

      PSPAR-AWORG

      And the error that appears is "No batch input data for screen SAPMP50A 1000"

      We are on Version 640 level SAPKA64016. Maybe something happened in a support pack that is causing this.....Thanks

  • author's profile photo Former Member
    Former Member
    Posted on Jan 10, 2007 at 01:54 PM

    We are attempting to process transaction PA30 using Batch Input

    Sessions via transaction SM35. The issue is there is no option

    for "Not a Batch Input Session" when processing BDC sessions from

    transaction SM35. The option is only available for BDC sessions created

    with the recorder and processed via transaction SHDB. We need the

    option "Not a Batch Input Session" when processing BDCs from

    transaction SM35. We are passing CTU_PARAMS-NOBINPT = 'X', but it

    doesn't appear to have any effect when processing the BDC from SM35.

    create BDC session data, setting CTU_PARAMS-NOBINPT = 'X',

    Go to transaction SM35, run BDC session. BDC

    runs as if "Not a Batch Input Session" was never set.

    tried NOBIEND = ‘X’ but that doesn't work either

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.