Skip to Content
author's profile photo Former Member
Former Member

Error with Mapping Lookup API using JDBC

All,

I have an interface that uses a JDBC lookup user defined function. Occassionally we get the following message:

<i>Problem when calling an adapter by using communication channel myJDBCLookup (Party: , Service: myJDBCdbase, Object ID: 0cdb888150ee36638cbfb100ff2e7161) XI AF API call failed. Module exception: 'Error ACK handling failed: java.lang.NullPointerException'. Cause Exception: (No information available)</i>

The only way I can duplicate this error is if I deactivate the myJDBCLookup communication channel and re-run the interface. In this case I get the same exact error. I know the commchannels were active when I ran and got the errors. Typically what I do is just restart the erred message and it runs fine.

I'm thinking I may be running into a timeout problem on the Oracle end of my call and XI is "timing out" or something like that.

My questions are:

1) whether or not XI has some timeout setting that I could increase that would hopefully mitigate this issue (I'm not an XI admin)?

2) would using a different Conflict Resolution (JDBC adapter config) or Number of Retries of Database Transaction on SQL error (JDBC Advanced adapter config) setting help?

3) Is there something altogether different I should be looking at?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on Jan 08, 2007 at 08:47 PM

    Hi,

    This blog may help u on to optimize the lookup-

    /people/sap.user72/blog/2005/12/06/optimizing-lookups-in-xi

    /people/sap.user72/blog/2005/10/15/jdbc-adapter-execution-mode-chained-or-unchained

    ALso check the Adapter Engine about time out parameters-

    hope this helps,

    Regards,

    moorthy

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 09, 2007 at 12:11 AM

    If your input message is not big may be u should try using direct jdbc connection rather than going through communication channel route. DId you try that before?

    --Archana

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.