Skip to Content
author's profile photo Former Member
Former Member

NWDS cannot find Java Virtual Machine

I just installed Developer Workspace (SAP NetWeaver 2004s SR2 (SP9)

) in my another laptop.

When I try to launch NWDS, I got the following message:

A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be available in order to run Eclipse. No Java Virtual Machine was found after searching the following locations:

3\bin\javaw.exe

But I have jdk 1.4.09 in my C;\ and set the environment variable:

In sytem variable, I set:

JAVAHOME = C:\j2sdk1.4.2_09

and Path: C:\j2sdk1.4.2_09\bin

The problem not solved with these config.

Thanks for advise.

KEnt

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jan 09, 2007 at 08:26 AM

    Hi Keant

    Richt click on Studio icon and go to Shortcuts and check whether the target is set to <b>"C:\Program Files\SAP\IDE\IDE70\eclipse\SapIde.exe" -vm "C:\j2sdk1.4.2_09\bin\javaw.exe"</b> or not. If that is correct then it works fine.

    Regards,

    Jhansi

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Jhansi,

      Doing this actually solve our problem:

      Richt click on Studio icon and go to Shortcuts and check whether the target is set to "C:\Program Files\SAP\IDE\IDE70\eclipse\SapIde.exe" -vm "C:\j2sdk1.4.2_09\bin\javaw.exe"

      Thanks.

      Kent

  • Posted on Jan 08, 2007 at 03:57 PM

    Hi Kent,

    i would suggest you re-install your JDK.

    Maybe it is a typo, but the environment variable is JAVA_HOME and not JAVAHOME.

    If you are sure your JDK is installed correct, you can also try to start the Developer Studio from the installation path with this command:

    <b>Example</b>

    SapIde.exe -vm c:j2sdk1.4.2_09binjavaw.exe

    Regards,

    Martin

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      add the following line as part of your short cut.

      -vm "C:\jdk1.5.0_07\bin\javaw.exe"

      Ex:"C:\Program Files\SAP\IDE\IDE71\eclipse\SapNetweaverDeveloperStudio.exe" -vm "C:\jdk1.5.0_07\bin\javaw.exe"

      Inside SapNetweaverDeveloperStudio.ini check for the entry

      -DJDK.1.5.0_HOME=C:\jdk1.5.0_07

      Modify the contents according to your system.

      Regards

      Ayyapparaj

  • author's profile photo Former Member
    Former Member
    Posted on Jan 08, 2007 at 07:10 PM

    Hi Kent,

    After installing the JDK set the sytem variable <b>JAVA_HOME to C:\j2sdk1.4.2_09.</b> As u have j2sdk1.4.2_09 there no problem with the version compatibility also.While installing the NWDS make sure that it is taking the java path that u have set already.

    If u have already installed then try to check the path of jdk that NWDS has taken.

    Regards,

    Jhansi

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 09, 2007 at 10:02 AM

    Hai kent,

    In NWDS>window>preferences>java>installedjres

    click add

    JreType-STANDARD VM

    jrename -j2sdk1.x.x

    jrelocation -c:\j2sdk1.x.x

    check the check box below press ok restart ur studio

    regards,

    Naga Raju

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.