Skip to Content

Resource /sap/bc/adt does not exist error

Hi All,

I am trying to import the standard apps to the SAP local webide using Import from SAP ABAP Repository method. After i get the list of destinations/systems in the dropdown , I select my backend system name. Then I get the known error "Cannot select the system. Check the configuration of ABAP Development Tools"

I know that the sap/bc/adt node in SICF needs to be active for the above. The node is active but when i run it on browser seperately it gives error "Resource /sap/bc/adt does not exist" in the xml. Screenshot is attached for the error.

Regards

adt-1.png (34.4 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    May 02, 2017 at 06:45 AM

    Hello Amber,

    Don't worry about the error message that you receive. This is to be expected, because the /sap/bc/adt service cannot be called directly from a browser.

    To verify whether your ABAP Development Tools actually work, I would suggest that you try them from the WebIDE in the SCP:

    Connecting Remote Systems

    Best regards

    Frank

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Frank,

      I know this is an old post but just to make sure regarding your comment "service cannot be called directly from a browser."

      Please test the example url below for you perusal:

      http://[server]:[port]/sap/bc/adt/oo/classes/[XX]/source/main?

      Please replace [xx] with any class and [server] and [port] with the appropriate icm settings.

      For functiongroups / modules and programs use the example below

      /sap/bc/adt/functions/groups/[xx]/source/main?

      /sap/bc/adt/functions/groups/[xx]/fmodules/xx/source/main?

      /sap/bc/adt/programs/programs/[xx]/source/main?

      I use this feature a lot to assist me during mass offline documentation of code on projects. If you use the share link on ADT on an object it will show and HTTP(if available) and ADT link.

      Marius

  • avatar image
    Former Member
    May 16, 2017 at 09:37 AM

    Hi ,

    I am facing similar issue.

    while accessing adt node in sicf and test, i received the similar xml message.

    Further i have generated the system connection file in webide eclipse folder and when i run the server and try to call the external repository, i receive error:

    "No authourization to access the resource /sap/bc/adt/discovery".

    I am not using any cloud connector. All i want is to connect to on premise gateway system.

    Server connection file:

    #ServiceDestination Description=XXX Gateway Type=HTTP TrustAll=true Authentication=NoAuthentication Name=XXX ProxyType=OnPremise URL=http://XXX.company.corp.co:8021 WebIDEUsage=odata_abap,ui5_execute_abap,dev_abap WebIDESystem=XXX WebIDEEnabled=true

    Am i missing some SU01 authourizations in my gateway abap box?

    please advise...

    ANkur

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 05 at 02:08 PM

    I am also facing similar issue while trying to deploy UI5 application from WEB IDE Personal edition .

    Did you find any solutions to this ?

    Thanks

    Sonia

    Add comment
    10|10000 characters needed characters exceeded