Skip to Content

Resource /sap/bc/adt does not exist error

May 01, 2017 at 01:37 PM


avatar image

Hi All,

I am trying to import the standard apps to the SAP local webide using Import from SAP ABAP Repository method. After i get the list of destinations/systems in the dropdown , I select my backend system name. Then I get the known error "Cannot select the system. Check the configuration of ABAP Development Tools"

I know that the sap/bc/adt node in SICF needs to be active for the above. The node is active but when i run it on browser seperately it gives error "Resource /sap/bc/adt does not exist" in the xml. Screenshot is attached for the error.


adt-1.png (34.4 kB)
10 |10000 characters needed characters left characters exceeded

Can you attach the SICF screenshot of the adt service?

Veeraraghavan Narasimhan

Please find the screenshot of SICF for ADT in the attachment

adt-1.png (74.6 kB)
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Frank Schuler
May 02, 2017 at 06:45 AM

Hello Amber,

Don't worry about the error message that you receive. This is to be expected, because the /sap/bc/adt service cannot be called directly from a browser.

To verify whether your ABAP Development Tools actually work, I would suggest that you try them from the WebIDE in the SCP:

Connecting Remote Systems

Best regards


Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Frank,

Actually internet does not work on that remote system on which we are working so we are not able to check in HCP.




Hi Frank,

I know this is an old post but just to make sure regarding your comment "service cannot be called directly from a browser."

Please test the example url below for you perusal:


Please replace [xx] with any class and [server] and [port] with the appropriate icm settings.

For functiongroups / modules and programs use the example below




I use this feature a lot to assist me during mass offline documentation of code on projects. If you use the share link on ADT on an object it will show and HTTP(if available) and ADT link.


Ankur Agarwal May 16, 2017 at 09:37 AM

Hi ,

I am facing similar issue.

while accessing adt node in sicf and test, i received the similar xml message.

Further i have generated the system connection file in webide eclipse folder and when i run the server and try to call the external repository, i receive error:

"No authourization to access the resource /sap/bc/adt/discovery".

I am not using any cloud connector. All i want is to connect to on premise gateway system.

Server connection file:

#ServiceDestination Description=XXX Gateway Type=HTTP TrustAll=true Authentication=NoAuthentication Name=XXX ProxyType=OnPremise URL= WebIDEUsage=odata_abap,ui5_execute_abap,dev_abap WebIDESystem=XXX WebIDEEnabled=true

Am i missing some SU01 authourizations in my gateway abap box?

please advise...


Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Ankur ,

Even I am facing the issue with the server , although I tried with a different server then its working. Looks to me something to be done from the ABAP server , but till now not sure what is that to be done. If you find , then please let us know also



Hi Ankur ,
i've got the same error. Have you resolved that issue ?

Sonia Kalra Mar 05 at 02:08 PM

I am also facing similar issue while trying to deploy UI5 application from WEB IDE Personal edition .

Did you find any solutions to this ?



10 |10000 characters needed characters left characters exceeded