Skip to Content
0

Refresh of data error: "MS SQL 2014: Unable to connect. Check your data access driver

Apr 30, 2017 at 09:46 PM

207

avatar image

I have connected Lumira 1.31 (desktop) to a SQL server and imported a data set

Now I close down Lumira and reopen – and try to refresh the data source

Get this error

I have taken a look at the below possible solutions – and implemented it

https://archive.sap.com/discussions/thread/3724752

https://launchpad.support.sap.com/services/pdf/notes/2240273/E

but I does not work

All the files SAPVI and sqlsrv.sbo points the the location where the jar file is placed

I use this jar = sqljdbc41 but have also tried with sqljdbc4 and sqljdbc. All with no luck

the sbo file looks like this

http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../sbo.xsd"> com.sap.connectivity.cs.java.drivers.jdbc.mssql.MSSQLDriver $ROOT$/drivers/java/dbd_jdbcwrapper.jar com.sap.connectivity.cs.java.drivers.jdbc.wrapper.JDBCWrapper Microsoft sqlsrv sqlsrv jdbc sqlsrv Query,Procedures sqlsrv,jdbc Yes No True 10 False Yes Yes False True MS SQL Server 2005 MS SQL Server 2000 MS SQL Server 7.x MS SQL Server 6.5 com.microsoft.sqlserver.jdbc.SQLServerDriver jdbc:sqlserver://$DATASOURCE$;DatabaseName=$DATABASE{replace44}lt;/Parameter> sqlsrv2008,sqlsrv,jdbc Always True com.microsoft.sqlserver.jdbc.SQLServerDriver jdbc:sqlserver://$DATASOURCE$;DatabaseName=$DATABASE{replace60}lt;/Parameter> sqlsrv2012,sqlsrv,jdbc Always Query,Procedures,Can picture-lumira-error.pngcel</Parameter> <Parameter Name="SSO Available" Platform="MSWindows">True</Parameter> </DataBase> <DataBase Active="Yes" Name="MS SQL Server 2014"> <JDBCDriver> <!-- Uncomment and edit the following lines to define java classes required by JDBC driver <ClassPath> <Path>your jar or class files directory</Path> </ClassPath> --> <ClassPath> <Path>C:\JDBC\qljdbc41.jar</Path> </ClassPath> <!-- Configuration is done for SQL Server 2012 JDBC Driver (2.0) --> <Parameter Name="JDBC Class">com.microsoft.sqlserver.jdbc.SQLServerDriver</Parameter> <Parameter Name="URL Format">jdbc:sqlserver://$DATASOURCE$;DatabaseName=$DATABASE{replace80}lt;/Parameter> </JDBCDriver> <Parameter Name="Extensions">sqlsrv2014,sqlsrv,jdbc</Parameter> <Parameter Name="Force Execute">Always</Parameter> <Parameter Name="Driver Capabilities">Query,Procedures,Cancel</Parameter> </DataBase> </DataBases> </DriverConfiguration>

10 |10000 characters needed characters left characters exceeded

Hello Rene - are you on the latest patch of Lumira, 1.31.4? If not could you update and try again?

0

Hi Tammy - yes I am on version 1.31.4 Build 133

And I have full license.

0
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
René Hvidberg May 04, 2017 at 11:36 AM
0

Hi - we found the solution. The underlying MS SQL server had a faulty user. We solved it by cloning the old user. then it works

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Rene,

I have the same issue, was this Faulty user a generic user, was the user working okay for other reporting from other sources?

This is because my user is generic user and works ok for all our reporting from our DW, and also used for SSMS and universe connections.We have no issues with any other reporting using this user.

Thanks.

0
Dazy Parker May 01, 2017 at 09:58 AM
0

Hello Rene,

Please check the TCP port number for the SQL database connection. Please go through this post: https://community.spiceworks.com/topic/1987362-cannot-connect-with-server-management-studio and read the answer Priyal, brand representative of Stellar data recovery.

Good Luck!

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Dasy

Thanks for the link - I have implemented the suggested solution. But with no luck. I will investigate the Firewall and the TCP port on the MS SQL side. I can see that Lumira has a lot of different firewall settings.

lumira-port.png (46.7 kB)
0

Hi

I can connect to the MS SQL via Excel run it, restart it and refresh without any problems

0