Skip to Content
author's profile photo Former Member
Former Member

Runtime Error: Cannot find root component repository object for application

My webdynpro JAVA application is throwing an inconsistent error, only in the live system:

com.sap.tc.webdynpro.services.exceptions.WDRuntimeException: <b>Cannot

find root component repository object for application

WDEmplServicesWebContentApp</b>

I don't see this error referenced anywhere is SDN or OSS.

The error seems to occur very infrequently, usually the first time a user logs

in and enters the application. Once a new browser is opened and the application invoked again, the error seems to go away.

This WebDynpro application has been running for a while without error. Recently,

I implemented a new application. It is a stateless Session Bean that

links and unlinks portal groups to roles. According to the new application's logs, it appears to be running fine. I'm not sure if this impacts the first webdynpro.

Here is how I recreate the error:

Log into EP6 SP14 portal. Click on the Employee Services portal role. The initial content of the role is the errant WebDynpro application. The WebDynpro presents a home page for the role and displays links to all content.

Here is the trace information:

com.sap.tc.webdynpro.services.exceptions.WDRuntimeException: Cannot find root component repository object for application WDEmplServicesWebContentApp

at com.sap.tc.webdynpro.clientserver.cal.ClientApplication.createApplication(ClientApplication.java:268)

at com.sap.tc.webdynpro.clientserver.task.WebDynproMainTask.createApplication(WebDynproMainTask.java:738)

at com.sap.tc.webdynpro.clientserver.task.WebDynproMainTask.execute(WebDynproMainTask.java:598)

at com.sap.tc.webdynpro.clientserver.cal.AbstractClient.executeTasks(AbstractClient.java:59)

at com.sap.tc.webdynpro.clientserver.cal.ClientManager.doProcessing(ClientManager.java:248)

at com.sap.tc.webdynpro.serverimpl.defaultimpl.DispatcherServlet.doWebDynproProcessing(DispatcherServlet.java:154)

at com.sap.tc.webdynpro.serverimpl.defaultimpl.DispatcherServlet.doContent(DispatcherServlet.java:116)

at com.sap.tc.webdynpro.serverimpl.defaultimpl.DispatcherServlet.doGet(DispatcherServlet.java:48)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)

at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.runServlet(HttpHandlerImpl.java:390)

at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.handleRequest(HttpHandlerImpl.java:264)

at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:347)

at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:325)

at com.sap.engine.services.httpserver.server.RequestAnalizer.invokeWebContainer(RequestAnalizer.java:887)

at com.sap.engine.services.httpserver.server.RequestAnalizer.handle(RequestAnalizer.java:241)

at com.sap.engine.services.httpserver.server.Client.handle(Client.java:92)

at com.sap.engine.services.httpserver.server.Processor.request(Processor.java:148)

at com.sap.engine.core.service630.context.cluster.session.ApplicationSessionMessageListener.process(ApplicationSessionMessageListener.java:33)

at com.sap.engine.core.cluster.impl6.session.MessageRunner.run(MessageRunner.java:41)

at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)

at java.security.AccessController.doPrivileged(Native Method)

at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:95)

at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:160)

Thank you for any insights,

Kevin

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Jan 10, 2007 at 02:33 PM

    Hi Kevin,

    You are not the only one in the world with this problem....

    The same problem occured on our machine this morning. And this was not the first time it occured.

    We stopped and started the server (Winhdows) and the problem was 'fixed'.

    BUT....it's still unclear what caused the error to occur....!!

    Kind regards,

    Maarten

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.