Skip to Content
author's profile photo Former Member
Former Member

Deployment exception

Hi all,

I am getting following Exception when I deploy my application

Jan 2, 2007 3:31:24 PM /userOut/deploy (com.sap.ide.eclipse.sdm.threading.DeployThreadManager) [Thread[Deploy Thread,5,main]] ERROR:

[003]Deployment aborted

Deployment exception : Cannot determine sdm host (is empty). Please configure your engine/sdm correctly !

When I check the j2ee server in SAP mmc, it is running perfectly.

When I ping the j2ee server port in the command port,it is pining perfectly.

When I check the J2EE Engine tab in NWDS, it is not running,it is showing red color.

i have checked the port in window -> preferecne-> sap J2EE Engine.

I am geeting the above said error.

Please give solution to solve this issue.

It is urgent please. Thanks in advance.

PonnusamyP

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 02, 2007 at 10:28 AM

    Try restarting the J2EE server using visual admin if possible.

    Best Regards,

    -Prashant.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 02, 2007 at 12:20 PM

    hi,

    restart the J2ee engine before deploying your application in NWDS all the are in green then only successfully deployed.

    Make sure those before deploying otherwise go to VA and restart the J2ee engine.

    There asking the SDM Password if u have that give otherwise give the admin password.

    then it might helps you.

    Thanks,

    Lohi.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      Is you are using the local server or remote server I mean your j2ee engine is your local system or another system.

      If it is in your local system goto windows-preference-j2eeengine in that select the second radio button and click the browse button then u will get the instance of the j2ee engine.

      Other go for the first radio button and give the msgserverhost is your Portal IP adderss and messageserverport is 3601.

      Then apply it might helps you.

      Otherwise ask your admin.

      Thanks,

      Lohi.

      Message was edited by:

      Lohitha M

  • author's profile photo Former Member
    Former Member
    Posted on Jan 03, 2007 at 11:08 AM

    Hi

    Try to add the host (IP address ) details in host file location: C:\WINDOWS\system32\drivers\etc\hosts file and reopen NWDS.

    Hope this Helps

    Ananda

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.