Skip to Content

SAPUI5 1.44.9 in SAP_UI 7.51 SP01 - possible?

Dear all,

I recently upgrades my Fiori hub server to 7.51 SPS 1 (on Prem - AnyDB) using Fiori Frontend Server 3.0 Upgrade Path.

It comes shipped with component SAP_UI 7.51 SP 1, hence SAPUI5 1.44.1. I'm pretty confident I can update that at least to 1.44.8 following this note https://launchpad.support.sap.com/#/notes/2429051/E.

However, notes for more recent patchlevels of SAPUI5 e.g. for SAPUI 1.44.13 https://launchpad.support.sap.com/#/notes/2463951/E state that they are "valid for SAPK-75102INSAPUI - SAPK-75102INSAPUI" and the patch will be shipped with SAP_UI 7.51 SP3.

I understand, that I cannot do a minor version upgrade of SAPUI5 through applying patch notes like the above. But given the latter note just pumps the patchlevel to 13 and keeps the minor version on 44, am I eligible to install when still staying put on SAP_UI 7.51 SP1 or would I need to go for SP 2 instead?

Many thanks and kind regards

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Apr 28, 2017 at 08:33 PM

    Hello Jens,

    You are correct, in that you can only upgrade your minor SAPUI5 version with a SAP_UI patch.

    However, once on a minor SAPUI5 version, you can patch this to any level available. Currently, I am running SAP_UI5 7.51 SP 0001 with SAPUI5 1.44.13.

    In fact, I believe this is what SAP recommend.

    Best regards

    Frank

    Add comment
    10|10000 characters needed characters exceeded

  • May 15, 2017 at 10:17 AM

    Just came back here to tie up some loose ends:

    I raised an incident at SAP and the very polite "call monger" said it would always be good to be up to date with one's SPs...

    After some back and forth I eventually got the answer (at least kind of) that I thought would be the outcome anyway: Note https://launchpad.support.sap.com/#/notes/2217489/E does apply. So we would be safe upgrading to 1.44.13 (or above)

    Cheers

    Jens

    Add comment
    10|10000 characters needed characters exceeded