Skip to Content
1

PAGE_BUILDER_CUST is missing for xsappsite

Apr 28, 2017 at 10:10 AM

294

avatar image

Hi ,

I have HANA Server (without Gateway or Newtweaver) , which i am accessing it through HANA Studio. When I tried to create Launchpad using xsappsite, it showing following error-

It depicts that /sap/opu/odata/ui2/page_builder_cust is missing .

I have gone through all similar threads but still not able to resolve. It seems that some HANA Content need to be installed.

Following roles are already assigned to my Username -

sap.hana.uis.db::SITE_DESIGNER

sap.hana.uis.db::SITE_USER

Kindly let me know, solution for this.

Regards,

sap.jpg (11.0 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Ivan Mirisola
Jun 02, 2017 at 09:14 PM
1

Hi,

I had the exact same issue. My user has the proper authorizations.
Tested on releases 122.06 and 112.
Tried re-importing the DU for UIS but it didn't help either.

Problem lies on the Eclipse Editor for the XSAPPSITE extension. When it attempts to load web resources on the server it fails. Usually the first time you start Eclipse it issues an SSL error - which most people tend to ignore. However, this leads to all resources from the page to fail. Thus, the editor is rendered broken.

Fortunately, the solution is quite simple - but not trivial to come up with :-)

  1. Open the Systems view in Eclipse and right-click the HANA system then select properties.
  2. Select the last item (named: "XS Proprerties"). Here is where Eclipse stores the defaul hostname and port to be called for web resources (including all Management Apps such as Monitoring, LCM, Cockpit, etc.)
  3. Enter the hostname in FQDN and the HTTP port of your server (not the SSL one).
  4. Deselect the option "Use HTTPS"
  5. After you hit OK, restart Eclipse and your XSAppSite will open without any errors.

Regards,
Ivan


Show 4 Share
10 |10000 characters needed characters left characters exceeded

Hi lvan,

I tried your solution by maintaining Host & port no. in 'XS properties' but still same error persists. Let me know, if you have any other solution.

Regards,

0

Did you use the ssl port or have you changed it to the non-ssl port?

What happens when you open the xsappsite?

0

I have added system using below settings

And I am getting same error in xsappsite as earlier.

capture.png (6.0 kB)
0

Hi Ankit,

What's your HANA release?

Could you please check your Eclipse Plugins and make sure they are up-to-date?

I use Eclipse Neon 3 with the Hana Tools installed directly from https://tools.hana.ondemand.com/neon.

If you are still using a particular version of HANA Studio I would recommend you testing on the above version instead. If that's not possible, than try updating the HANA Studio to the latest version - which should be downward compatible with earlier releases of HANA. I've learned that HANA Studio Plugins contains several bugs if you don't update them regularly.

Regards,

Ivan

0
Eric Chen May 11, 2017 at 09:29 AM
0

Hello,

We are getting the same error as well with HANA SPS12 (122.08) running HANA Studio 2.3.15. We've seen this error in the past and upgrading HANA studio worked but in this case I believe we're using the correct version of studio for the version of HANA.

After some troubleshooting and looking at the traffic between Studio and the server it seems like that error message is erroneous and the actual error is a request to /sap/hana/uis/odata/uis_fioricatalogs.xsodata/FIORI_CATALOGS?$format=json is failing.

The request is being redirected to the forms login page and it doesn't seem like studio knows what to do with this and can't login.

Just to verify that this was the issue we changed the authentication method to Basic on the service which caused a login window to popup and after logging in we were able to use the appsite editor. This involved changing the xsaccess file for the odata service in SAP delivered code which clearly is not a valid solution. Seems like there's some configuration issue or maybe a bug.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hello Eric,

authentication method is already set to Basic in my xsaccess. But I am still getting same error. Let me know, if you have any other solution.

{
     "exposed" : true,  
                  
     "authentication" :                                            
            {
               "method": "Basic"   
            }
}
0