Skip to Content
0

How to change the RMI address in SCC3.3 of ASE16 CE?

Apr 28, 2017 at 06:25 AM

35

avatar image

Dear All,

I'm trying to create a cluster in ASE16 CE -- before that, I need to connect to the scc agent on both nodes -- 10.128.244.181 and 10.128.244.182.

So I modified the $SYBASE/SCC-3_3/services/RMI/service-config.xml. Edit the value of "address" from localhost to 10.128.244.181. like this --

asece@hostname2change:~/SCC-3_3/services/RMI> cat service-config.xml
<?xml version="1.0" encoding="ISO-8859-1"?>
<service-config id="RMIService" version="3.2.0" name="RMI Service" provider-name="Sybase, Inc." register-on-startup="true" mbean-type="Model MBean" mbean-descriptor="mbean-descriptor.xml" arl-config="arl.xml">
<dependencies />
<properties>
<set-property property="address" value="10.128.244.181" />
<set-property property="addressType" value="static" />
<set-property property="port" value="9999" />
<set-property property="timeout" value="43200" />
</properties>
</service-config>

But everytime -- when I restarted the scc.sh -- to my surprise -- I found the address was changed back to localhost again so the scc agent RMI always stay on the "localhost:9999"... Then my sybcluster can only connect to the local scc agent and can't proceed the cluster configuration...

And I also tried to start scc.sh with parameter -- -a "10.128.244.181" -- But I found the scc agent can't startup with this parameter ... No idea now, so have to ask for help from here...

Thanks in advance for any help or idea.

Regards

Eisen

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Eisen Wang
May 02, 2017 at 05:56 AM
0

Solution found -- the "-a" can't use IP address , it must use hostname as the parameter value --

so after I start the scc with "-a node1_hostname" -- then the RMI address were set to the correct IP.

Share
10 |10000 characters needed characters left characters exceeded