Skip to Content
0

Parameter DATABASE_SID must not be empty for a connect to a multiple-container system!

Apr 27, 2017 at 05:52 PM

583

avatar image
Former Member

Hi SAP Community,

My team and I are trying to do a fresh install of SAP S/4 HANA 1610 on prem via SAPinst and we've run into the the following error. We have another DB installed and this is our second DB as we are attempting to use the MCOS (Multiple Components in One System) architecture .

'Error during execution of HdbCmdClazz 'CREATE_SQL_ROLE_USER_SEQUENCE' : class com.sap.hdb.sl.lib.utils.cmd.clazz.CmdClazzParameterFactory, parameters received. Start execution. Check HdbCmdOut.log and HdbStdout.txt for further information. Thu Apr 27 18:28:02 BST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | Parameter DATABASE_SID must not be empty for a connect to a multiple-container system!'

We tried following the 'SUM DMO migration to multi tenant fails' steps suggested by Former Member which was to modify script SUM/abap/bin/hdbsllib by adding DATABASE_SID=E15 but it doesn't seem to work. Appreciate any help as we've been trying to solve it all day without success and we're unsure what to do now :(

Screenshot and log file attached.

Regards

Sean Lim

Thu Apr 27 18:04:07 BST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | *************************************************************

Thu Apr 27 18:04:15 BST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | Start new command section

Thu Apr 27 18:04:15 BST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | Version of com.sap.hdb.core.jar | Changelist: 168759 | API-Version: 00

Thu Apr 27 18:04:15 BST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | Version of com.sap.hdb.sl.lib.jar | Changelist: 169533 | API-Version: 35

Thu Apr 27 18:04:15 BST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | Name of HdbCmdClazz: class com.sap.hdb.sl.lib.utils.cmd.clazz.CreateSqlRoleUserSequence

Thu Apr 27 18:04:15 BST 2017 | com.sap.hdb.sl.lib.utils.cmd.clazz.CreateSqlRoleUserSequence | ------------------------------------------------------------------------

Thu Apr 27 18:04:15 BST 2017 | com.sap.hdb.sl.lib.utils.cmd.clazz.CreateSqlRoleUserSequence | Next clazz for BatchExecution is: CreateRole

Thu Apr 27 18:04:15 BST 2017 | com.sap.hdb.sl.lib.connection.sql.JdbcDriver | URI: file:/tmp/sapinst_instdir/S4HANA1610/CORE/HDB/INSTALL/STD/ABAP/ngdbc.jar

Thu Apr 27 18:04:15 BST 2017 | com.sap.hdb.sl.lib.connection.sql.JdbcConnection | Last user: System, New user: _SYS_DUMMY_

Thu Apr 27 18:04:16 BST 2017 | com.sap.hdb.sl.lib.connection.sql.JdbcConnection | Start new connection with connect URL: jdbc:sap://abc.abc.com:30513 connect user: _SYS_DUMMY_

Thu Apr 27 18:04:16 BST 2017 | com.sap.hdb.sl.lib.connection.sql.JdbcConnection | Last user: _SYS_DUMMY_, New user: System

Thu Apr 27 18:04:16 BST 2017 | com.sap.hdb.sl.lib.user.password.HdbPassword | Error retrieving password policy from database: com.sap.hdb.sl.lib.exceptions.HdbException: Parameter DATABASE_SID must not be empty for a connect to a multiple-container system!. Using default values.

capture.jpg (256.1 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

avatar image
Former Member Apr 27, 2017 at 07:11 PM
0

Hi,

I am getting same error on installing NW 7.5 on SAP HANA database. I am using SWPM SP19.

Please keep posted on any solution.

Regards,

Arun

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Arun,

Good Day !

I am facing the same issue with SWPM 1.0 SP20 version while installation of S4HANA 1610.

Did you get any solution for this issue ? I have already installed DB using hdblcm for SAP HANA 2.0 SP02 .

Please kindly share soluition if you have got it ..

Thanks & Best Regards

Satish

0
avatar image
Former Member Apr 28, 2017 at 02:38 PM
0

Hi,

I am getting same error on installing ERP 6 Ehp8 on HANA DB. And also using SWPM SP19. Please help.

Regards,

Ru

Share
10 |10000 characters needed characters left characters exceeded
Roland Kramer
May 02, 2017 at 08:11 AM
0

Hello
I suggest (what I did) to stop the SAP Installation with SWPM and start first with the SAP HANA 2.0 Standalone Installation .

As I did this 2 times due to a disk error for S/4 this is the best approach to go forward here. Once the HANA Database is installed, the SWPM will find the the DB SID correctly.

For B/4HANA I recommend not to use HANA 2.0 to avoid unwanted system behaviors afterwards and also run the SAP HANA Standalone Installation first.

Best Regards Roland

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Roland,

I tried as you recommended by installing SAP HANA 2.0 standalone installation and then running DB instance install in SWPM for NW 7.51 in distributed environment. But it is trying to create Multitenant database instead of Single container. I have provided same database SID in hdblcm and in SWPM. Is this something you came through? Please assist.

Regards,

Arun

0
Former Member

Hi @Roland Kramer,

Sorry for the late reply, we did your SAP HANA 2.0 Standalone Installation first and it has solved the error. Thank you for your help!

Regards

Sean

0
Roland Kramer
May 03, 2017 at 07:25 PM
0

Hello
This is due to HANA 2.0 SP01.
From this Version onwards, you will be forced to Implement HANA as MTC even it is not your Intension.

Rather user HANA 1.0 SP12 Rev. 122.07 or higher together with BW/4HANA as you still can create a single HANA Instance with this Version

Best Regards Roland

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Roland,

Thanks for the info. So there is no option to implement single container database from HANA 2.0 SP01? If so, do SAP released any note or official document explaining this?

Regards,

Arun

0

Hello
That's right. HANA 2.0 doesn't allow anymore the creation of a single Instance.

At this time there are no plans to change this

Best Regards Roland

0