Skip to Content
0

GenericTile not been displayed inside a Page content

Apr 27, 2017 at 09:57 AM

53

avatar image

I am using sap.m.GenericTile inside an XML view (directly inside view without Page ) and its working fine.

However I wanted to have the Tile inside a sap.m.Page . When i write the code for Tile inside the content of Page , the output does not show any tile. There is no error in the console either.

In the code below once the Page and Content part is uncommented , the tile is not displayed in the output

<core:View xmlns:core="sap.ui.core" xmlns:mvc="sap.ui.core.mvc" xmlns="sap.m" 
           xmlns:l="sap.ui.layout"
		controllerName="TileTest.controllers.Main" xmlns:html="http://www.w3.org/1999/xhtml">
	<!-- <Page title="">
		<content> -->
				<GenericTile
					backgroundImage="images/Sap_Img1.jpg"
					frameType="TwoByOne" press="pressOnTileOne">
					<tileContent>
						<TileContent footer="August 21, 2016">
							<content>
								<NewsContent
									contentText="SAP Unveils Powerful New Player Comparision Tool Exclusively on NFL.com"
									subheader="Today, SAP News">
								</NewsContent>
							</content>
						</TileContent>
					</tileContent>
				</GenericTile>
                             <!-- </content>
	                     </Page> -->
</core:View>


10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Jun Wu Apr 27, 2017 at 03:00 PM
1

put your page in app. seems to be known issue.

Share
10 |10000 characters needed characters left characters exceeded
VIPLOVE KHUSHALANI Apr 27, 2017 at 10:46 AM
0

Hi Amber ,

Can you just check in the developer options that whether your generic tile is rendered or not (its HTML code is there in the developers tool F12)

thanks

Viplove

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Viplove,

Yes I checked , its been rendered in HTML showing the highlighted area in white as the area of the tile. Please find the attached screenshot

tiles-1.png (64.8 kB)
0
Srinivasan S Apr 27, 2017 at 02:14 PM
0

Hi Amber,

Try using <mvc:View> instead of <core:View>. The Generic Tile should display inside the page content.

Regards,
Srinivasan

Share
10 |10000 characters needed characters left characters exceeded