Skip to Content
0

HANA Express : XSA Build Error hdi-builder is not available for workspace

Apr 27, 2017 at 02:41 AM

570

avatar image
Former Member

Hello,

I am running HANA Express 1.0 on AWS. I was following the sample application build blog . While building the HDB module I am getting the error which says "hdi-builder is not available for workspace workspaceXXXXXXXX " . I followed the comments on the blog but could not resolve the issue. So far I have done the following:

  1. xs apps command tells me that all the apps including di-core are running under space SAP. I have tried to restart the di-core.
  2. I have set the dev space to SAP. I have assigned my user XSA_DEV the SpaceDeveloper for same space.
  3. I have rebuilt the app 3-4 times from scratch to make sure di-builder gets redeployed.
  4. I have tried restarting HDB and rebuilding the app.

Any idea what the next steps should be?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

avatar image
Former Member May 15, 2017 at 08:00 AM
0

Hi Anuj,

you need to log on into the di-space-enablement-ui, you can get the link with xs app di-space-enablement-ui –urls.

Run that and it will install the di-builder into any space you select (in your case the DEV space).

Share
10 |10000 characters needed characters left characters exceeded
Nachshon Vagmayster
Jun 04, 2017 at 07:03 AM
0

Hi Anuj

Have you managed to overcome this issue? First step is to make sure the di-builder is deployed in the space you want to develop in. If that is the SAP space than make sure di-builder is running in that space. If not follow the instructions as mentioned by Houssem above.

Share
10 |10000 characters needed characters left characters exceeded
Valery Semichev Jun 30 at 07:12 AM
0

Hi!

Just wanted to document a solution for future reference. This issue is quite common on VM HANA Express environment.

The easy run is

xs restart di-space-enablement-ui

in step 1, but it usually doesn't help and you need to go to step 2.

Find the URL for DI CORE Space Enablement admin interface by running

xs a | grep di-space-enablement-ui

usually the PORT is 51024.

Open this URL in separate browser window (better Chrome Incognito mode), login with XSA_ADMIN (not the usual XSA_DEV which will through Forbidden exception) and Enable required Space. This operation will take a few minutes. Please be patient.

Done.

Share
10 |10000 characters needed characters left characters exceeded