Skip to Content
0
Former Member
Dec 19, 2006 at 09:23 AM

Stopping runaway BPE workflow (infinite loop on synchronous send)

62 Views

Hi All,

I have an issue with an inadvertant infinite loop in an Integration Process which is now seemingly unstoppable. I discovered that it was looping (branch that it is looping over includes a syncronous send, so I was getting lot's of messages in SXMB_MONI) and so started to look into why. I now know what the issue was with my Integration Process and know how to fix but I can't stop what is already running.

I search these forums and saw the information about SWWL in other threads but this is no use to me for some reason. I can remove all filters and still I only see the active and completed work items for the "block" and "sync send" which are causing the issue. When I delete all in SWWL it only deletes the COMPLETED ones, and gives me an error on the STARTED ones saying that it is locked by user WF-BATCH... and SM12 is useless for solving this because as quickly as I can remove the locks, they are replaced.

I tried Michals weblog suggestion of stopping the BPE using txn SWF_XI_ADM_BPE - but strangley although I could stop the BPE completely it did not stop these work items being continually created.

I assume there must be a background job, by WF-BATCH user which is creating these work items but I just have no clue how to stop it... any ideas!?

P.S. Have tried changing/deleting/removing and re activating the Integration Process, to the point where the steps which are continuously running no longer even exist in the active process/workflow, but the old one is clearly still going strong somewhere!

Many thanks,

Chris