Skip to Content
avatar image
Former Member

.CSV file is not picked up by sender file channel in SAP PI 7.5

Hello,

We are working on a migration project from SAP PI 7.11 version to SAP PO 7.5(SP05) version.In PI 7.5 we are facing a problem where in the sender file communication channel is not picking up the .csv files from the FTP server.But the exact same sender channel configuration works fine on SAP PI 7.11.

The Error what we are seeing on SAP PO 7.5

Communication channel error log : Could not process due to error: com.sap.engine.interfaces.messaging.api.exception.MessagingException: com.sap.aii.adapter.file.ftp.FTPEx: 226 Unexpected reply codeTransfer complete

NWA error log: Error during disconnect from ftp server ******, ignored: com.sap.aii.adapter.file.ftp.FTPEx: 250 Unexpected reply codeDirectory successfully changed

Channel Config: capture.png capture1.png capture2.png

Also there is another channel on SAP PO 7.5 which picks up the .cps file from the exact same server and directory location that works fine too. Its strange that we are having issues with only processing the .csv files.

I also tried with quality of service as exactly once , that dint work either.

Can anybody tell me what could be the issue here please?

Any inputs and pointers would be much appreciated.

capture.png (30.6 kB)
capture1.png (26.9 kB)
capture2.png (21.2 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Jul 24, 2017 at 01:48 AM

    Hi Kavita,

    We are facing a sismilar issue on PO 7.5 SP07.

    Did you find the solution for this issue.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 18, 2017 at 04:44 PM

    Hi Kavita/Abhinay,

    We are also facing the same kind of issue on PO 7.5. Did you guys find any solution for this issue.

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 05 at 10:52 AM

    It seems this has not been answered yet. I ran into the same issue when migrating from an older dual-stack PI to single stack PO 7.5.

    SAP has released a note Note 2615224 - "226 Unexpected reply code" in PI File channel while File Modification Check is activated.

    The solution is rather simple, just set the Msecs to Wait Before Modification Check parameter to "0".

    IIRC the modification check never worked with FTP in older versions of PI, and the new implementation seems to have an issue with it in FCC-scenarios.

    Add comment
    10|10000 characters needed characters exceeded