Skip to Content
avatar image
Former Member

Dispatcher is not starting in SAP after oracle upgrade to 12c

I have upgraded the oracle database to 12c and I am able to connect to the database and after executing the command startsap r3, the application is starting but the dispatcher is not running. After checking the dispatcher its showing below error.

dpmon=>sapparam(1c): No Profile used. dpmon=>sapparam: SAPSYSTEMNAME neither in Profile nor in Commandline DpMonInit failed - possibly no dispatcher running DpMon: External/Internal dplib version: 124/150.

Please suggest.

Add comment
10|10000 characters needed characters exceeded

  • Hi Aron,

    Please tag "sap netweaver abap" for your question, because this is not a database issue any more, so you have limited resource if you only tag "oracle database".

    Anyway regarding this issue, please attach dispatcher trace, dev_w* traces.

    Best regards,
    James

  • Get RSS Feed

5 Answers

  • Apr 25, 2017 at 09:34 AM

    Hi Aron

    Can you attach the dev_disp and dev_w0 log .

    Thank you

    Jayanth

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 25, 2017 at 10:36 AM

    Hi Jayanth,

    I have checked the logs file, the application is starting with the wrong instance profile. I have stopped the application and remove that wrong file but still the application is starting with that same profile.

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 25, 2017 at 01:57 PM

    Hello,

    it looks your work processes are not able to connect to DB. Since Oracle 12c SAP workprocesses are using only SSFS to connect to DB (instead of OPS$). Please configure SSFS as per SAP notes 1639578 and 1622837. Some details can be found also here: https://blogs.sap.com/2017/03/20/upgrade-oracle-database-from-11-to-12c/

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 25, 2017 at 04:58 PM

    Hi,

    Attach dev_w0 log file for more info. & Did you perform all post upgrade steps as mentioned in upgrade guide?

    This could be because of wrong environment variables.

    Regards,

    Harish Karra

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 26, 2017 at 11:28 AM

    Hi All,

    The issue has been resolved. the issue was with the shared memory.

    Thanks for your support.

    Add comment
    10|10000 characters needed characters exceeded