Skip to Content
0

Avoid row aggregation for -1 and 1 quantity

Apr 24, 2017 at 09:17 AM

19

avatar image
Former Member

Hi all,

I have a report that lists rows from invoices. The pb is that my report aggregates the lines with "-1" and "1". So instead of 2 rows with -1 and 1 for quantity, I have one row with 0. How can I solve this? With "avoid duplicate rows aggregations" it will avoid aggregation for all rows, so it's not an option. Thank you in advance,

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

AMIT KUMAR
Apr 24, 2017 at 09:22 AM
0

make you measure object to Dimension object and without sum aggregation.After that you will get two rows.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Amit,

But if I use a dimension, the output would be the same as activating "Avoid duplicate row aggregation", wouldn't it? What we need is: for rows with -1 and 1 for quantity, we need the grain level, while for the others, we need the aggregation. I'll try to attach a print screen with the desired output vs. the

Output with Avoid duplicate row aggregation activated/dimension object instead of measure. Many thanks

0
avatar image
Former Member Apr 24, 2017 at 11:16 AM
0

Here are the exemples:


felxm.png (25.1 kB)
Show 1 Share
10 |10000 characters needed characters left characters exceeded

After converting to dimension object then in webi query properties untick the check box "retrieve duplicate rows" and refresh.

0