Skip to Content
0
Dec 12, 2006 at 09:58 PM

SDM errors deploying support packs

36 Views

We're trying to apply SPS 08 for Solution Manager 4.0. We're at SPS 06 already from the initial installation. The ABAP kernel & support packs have been applied successfully; when we launch JSPM and it catalogs the deployed components via the SDM, the connection is terminated. Looking in the SDM we see errors like this:

Dec 12, 2006 3:27:39 PM Info: CAF: Sync deployment...

Dec 12, 2006 3:27:39 PM Info: CAF: Component: software component 'CAF'/'sap.com'/'MAIN_APL70P06_C'/'1000.7.00.6.0.20060221161956'

Dec 12, 2006 3:27:39 PM Error: CAF: Location of software component 'CAF'/'sap.com'/'MAIN_APL70P06_C'/'1000.7.00.6.0.20060221161956' unknown.

Dec 12, 2006 3:27:39 PM Error: CAF: system component version store not updated.

We get that same error for the following components: CAF, CAF-UM, ADSSAP, BI_UDI, KM-KW_JIKS, SAP_JEECOR, JSP_JTECHF, UMEADMIN, BASETABLES, BI_MMR, LM-TOOLS, SAP_JTECHS, SAP-JEE (13 components in all).

When I look at the /usr/sap/<SID>/DVEBMGS<##>/SDM/program/config/sdmrepository.sdc file for any of these (let's pick on CAF for fun), I see:

<Sca>

<SoftwareComponent>

<Name>CAF</Name>

sap.com

<Location>MAIN_APL70P06_C</Location>

<Count> 1000.7.00.6.0.20060221161956</Count>

</SoftwareComponent>

<Release>7.00</Release>

<SPNumber>6</SPNumber>

<SPPatchLevel>0</SPPatchLevel>

<RelativeLocation isUnknown="true"></RelativeLocation>

</Sca>

That <RelativeLocation isUnknown="true"> tag looks like it may be a problem... when I look at the component information via the URL (http://host:port/sap/monitoring/ComponentInfo) it shows all 13 "missing" components and their locations (MAIN_APL70P06_C). There are also other components with the same location (e.g. caf/runtime/security/content & tc/lm/webadmin/httpprovider/lib) that have the same location, so it really seems to be confined to these components.

I've dug around in OSS a bit and found note 756084 with common SDM problems; it makes a reference to note 828978 for this specific error, but that note talks about a system copy where the database is copied but not the SDM config file; it does talk about doing an 'SDM systemcomponentstate' call to sync the BC_COMPVERS table with the deployed components (see also note 910073).

I tried the sync and got the same response.

Has anyone else seen this before?

Thanks,

Rich