Skip to Content
0

SAP Adobe Forms (SFP) - Inserting an image outside of SAP

Apr 22, 2017 at 10:59 AM

80

avatar image

Hi SCN,

I'm trying to build a signed PDF form dynamically using a UI5 front-end application. The idea is that a user can pull up a document on the front-end and pass certain values back to SAP to create a PDF using Adobe Forms (e.g. a signed POD to be attached to a delivery using GOS). On top of that I'd also like to pass a signature image (which is created in the front-end) to be included in the creation of the PDF, which will then be saved to SAP Office.

I've searched the forum and managed to get the image into the PDF document using the MIME repository, but this is impractical. I don't think it's efficient to save each individual signature in SAP before adding it to the PDF?

My issue lies in the addition of the signature image. I've tried to pass both the BASE64 and converted XSTRING formats to the form but the image simply wont show. It does work when I pass the converted XSTRING of a MIME object but when I try to pass an XSTRING of a non-MIME object it doesn't work.

Is this possible with Adobe forms to use an XSTRING from an object that lies outside of SAP? Or is there some way to assign the BASE64 string to the image url? I've tried a few variations of the above and I can't get it to work at all without using the MIME repository.

I've read that this might be because of a security change to Adobe Forms but I'm not sure if this is actually the case?

Any help or guidance would be very much appreciated!

Thanks,

B

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Brandon Lastname May 04, 2017 at 12:41 PM
0

Hi Guys,


I managed to find the issue. I was not stripping away the initial base 64 text from the string. Once I removed it, the converted XSTRINg rendered the image perfectly.

Share
10 |10000 characters needed characters left characters exceeded
Evgeny Gubenko Apr 24, 2017 at 11:00 AM
0

Hi!

Did you try to set the image file on the PDF directly via script (see the link)

https://forums.adobe.com/thread/1072747

Evgeny

Share
10 |10000 characters needed characters left characters exceeded
Brandon Lastname Apr 25, 2017 at 08:44 AM
0

Hi Evgeny,

Thanks for the advice. I did try as you suggested but still no luck.

I think the issue lies in how I'm decoding the BASE64 from the front end to XSTRING, using SAP. I don;t save or upload the file from anywhere, I simply take the BASE64 code try convert it to XSTRING. When I decode an image that has been save to the MIME repository the output XSTRING works perfectly.

Share
10 |10000 characters needed characters left characters exceeded