Skip to Content
avatar image
Former Member

Crystal Reports 10.5.2 crashes the IIS worker process??

I have Crystal reports Basic for Visual Studio 2008 (x64) version 10.5.2 installed on a Windows Server 2012 R2 x64 operating system with IIS 8.5 installed.

When executing a SOAP web service on the asmx page in my web browser, the request is handled by the worker process in IIS which then calls my code where I create a report, export it to a stream and return the raw data as a string. However, the moment I attempt to call the function SetDataSource() of the ReportDocument object, the w3wp.exe crashes leaving behind a log in the event viewer and returning a connection reset error back to the client (browser)

The underlying code is not the issue as calling the same code from a desktop application works flawlessly.

However my overall question is, this issue that I'm experiencing, is it a known bug? Does someone with a similar setup have this working? If so, where did I go wrong? Should I not be using a 64-bit architecture, or are there special permissions needed?

I've attached the errors logged in event viewer for more details. worker-process-crash-logs.txt

Thank you,
Mikael

----------------------

I've seen a few threads suggesting that Crystal Reports 10.5 DOES NOT work with IIS 8+, is this true???

Note: My tests suggest it works on Windows Server 2012, but it kills the w3wp.exe every time.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Apr 24, 2017 at 07:32 PM

    Hi Mikael,

    Correct, CR for VS 2008 ( CR 10.5 ) is old technology and was never tested on newer OS's or WEB Servers.

    It should work though, use Debugdiag on the IIS process and see if it catches more info.

    Make sure all dependencies are 64 bit mode also.

    Does it work in 32 bit IIS mode?

    Don

    Add comment
    10|10000 characters needed characters exceeded