Skip to Content
0

Job scheduled on HANA XS, but does not start - what to do?

Apr 21, 2017 at 01:59 PM

241

avatar image

Hi, I have an issue with scheduling jobs on my HANA Express instance.

I am able to define a job and schedule it, but the job does not start - see attached screenshots.

In the table _SYS_XS.JOB_LOG (screenshot) I can see, that the start date is 2hrs earlier than defined in the XS Job tool - but even scheduling the job 2 hrs ahead did not help.

The jobs appear all the time as scheduled.

I have tried to schedule it with my own user as well as with the system user.

My user has authorizations:

sap.hana.xs.admin.roles::JobAdministrator

sap.hana.xs.admin.roles::HTTPDestAdministrator

What can be the reason for the jobs to not start?

What should I check?

With best regards,

Krzysztof.

jobs.jpg (78.5 kB)
scheduler.jpg (104.0 kB)
-sys-xsjob-log.jpg (45.8 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Florian Pfeffer
Apr 21, 2017 at 03:18 PM
0

You are just showing the design-time object for an XS job.

But did you also activate the job scheduler itself. Please check it in the XSC Admin Tools -> XS Job Dashboard.


Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Florian,

the scheduler is enabled. To be 100% sure I have switched it off and then on again.

The weird thing is, that the jobs appear active in the XSC Job Dashboard, but they are not.

With best regards,

Krzysztof.

0
avatar image
Former Member Apr 21, 2017 at 05:16 PM
0

One time, I gave the execution time in PST when it should have been in UTC, in the cron file and looking into logs to see why the job did not start :). Just saying.

Share
10 |10000 characters needed characters left characters exceeded
Krzysztof Bulanowski Apr 21, 2017 at 08:51 PM
0

Hi Florian,

I have checked it as well - the scheduler is enabled - see attached screenshot.

You can also see below, that 2 jobs "are" active, but they are not.

I have also tried to disable and enable the scheduler, but it did not help.

Any ideas?

Many thanks and best regards,

Krzysztof.


Share
10 |10000 characters needed characters left characters exceeded