Skip to Content
avatar image
Former Member

SAP IDM 8.0 Update ABAPUser

Hello IDM Experts,

I am working on SAP IDM 8.0 Installation and but when i am trying to update a user, getting below error.

"putNextEntry failed storing

Exception from Modify operation:com.sap.idm.ic.ToPassException: Exception modifying user com.sap.conn.jco.JCoException: (101) JCO_ERROR_CONFIGURATION: Initialization of repository destination IDM_DEST_1492685212954 failed: Parameter ABAP application server host ('ashost') is missing"

It seems somehow privilege i have are missing something and not able to read system details.

Thanks!

Saurabh

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Apr 25, 2017 at 08:29 AM

    Hello Saurabh,

    the error says "Parameter ABAP application server host ('ashost') is missing". So have you checked the constants for that repository to see if the parameter is filled?

    .

    Regards,

    Steffi.

    Add comment
    10|10000 characters needed characters exceeded

  • May 16, 2017 at 05:32 AM

    Hello Saurabh,

    As mentioned by Steffi and Hendrik, the issue is the system details are not properly maintained in the Repository constants or else the system may not be available.

    Regards,

    DP

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Steffi,

      Apologize for late reply.

      I don't think we any longer have specific hook tasks in IDM 8.0, below is one of the comment from upgrade guide.

      "There are no hook task repository constants in version 8.0. The plug-in processes of a repository are now referenced by repository type constants that are defined on the repository type. However, when upgrading from version 7.2 to 8.0, hook task repository constants are transformed into repository type constants with override and can be edited in the SAP Identity Management Administration User Interface."

      we have repository type constants now and I have attached those details.

      Please let me know in case I am missing anything.

      Thanks!

      Saurabh

  • avatar image
    Former Member
    May 04, 2017 at 07:45 AM

    Hey Saurabh,

    I have to agree with Steffi. This really looks like there is a basic issue with your connector to this ABAP Client.

    Does the Initial Load Job work? Maybe you have a Connection Test Job (delivered in rapid deployment solution or similar)?

    You could try to enter something different into the parameter like "test" and see whether this causes a different error message?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Hendrik,

      Yes the load jobs are working fine.

      Issue primarily comes when we try to assign a privilege to a new user or updating the access via load job.