Skip to Content
avatar image
Former Member

Is it possible to use an older version of the SAPUI5 Theme Designer?

I´m trying to create a design for an sap fiori app with the theme designer based on the bluecrystal design. I´m using the Theme Designer via the SAP Cloud Platform with a Trial developer account. The Problem is, i want to create a design for a fiori app based on SAPUI5 1.28. I created a sample app from template with SAPUI5 1.28 and started the theme designer. By creating a new theme i got the error that there are versions discrepancies between my app (1.28.45) and the theme repository (1.44). Is it possible to use an older version of the theme designer in the SAP Cloud Platform, so i can create a theme for an older fiori app? Or is it not possible at all to create a design with the current theme designer on the cloud platform for an app at Version 1.28?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Apr 20, 2017 at 01:35 PM

    Hi Lukas,

    You can start the UI theme designer with (almost *) all SAPUI5 versions that are available on SAP Cloud Platform.

    e.g.: https://themedesigner-themedesigner.dispatcher.hanatrial.ondemand.com/index.html?sap-themeroot=/themeroot/1.28.45

    See also SAP Note: https://launchpad.support.sap.com/#/notes/2306045/E

    It is important to create the theme for the exactly same version that you want to use in your application. Because there might be rendering errors.

    • You can upgrade the theme later (import/export in Theme Designer started with new version) when your upgrade your application
    • Downgrade of themes is not supported

    You can find more information about the theme compatibility in my video: https://www.youtube.com/watch?v=lbYqkmVRdpg

    Best regards,

    Uwe

    *: Some early versions are missing

    Add comment
    10|10000 characters needed characters exceeded