Skip to Content
0

Wrong XSUAASERVER configuration in Developer Edition SPS12 (v124)

Apr 18, 2017 at 01:40 PM

160

avatar image

Dear SAP cal support,

I use the SAP HANA Developer Edition SPS12 v124 from cal.sap.com on Microsoft Azure. The Smart Data Streaming part works well in most cases.

In order to combine SDS with XSA I receive errors based on a wrong port assignment of the xsuaaserver component.

I wanted to logon via XSA CLI using

xs -a http://.....:30030

By doing this I found out that the xsuaaserver is listening on Port 30031 although it seems that the configuration of XSA components directs to port 30032.

Authenticating...

Authentication failed. UAA at http://vhcalhdbdb:30032/uaa-security is not up.

I tried to reset the parameter daemon.ini -> xsuaaserver -> arguments to this port but did not work. By not being able to access XSA administration I am not able to do anything.

Are you aware of this error?

Thank you very much in advance for your help.

Kind regards

Martin

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Lucia Subatin
Apr 18, 2017 at 04:13 PM
0

Hi, Martin,

Why can you not access XS administration ui to check on the running applications? The right port for xs login is 30030 (xs login -a https://vhcalhdbdb:30030 is correct), it will use 30031 and 30032 internally. Please leave the 30031 port in the daemon.ini config.

Here's a list of ports that need to be open for XSA and a link to a troubleshooting for the xsuaa error you are getting:

https://blogs.sap.com/2017/02/01/uaa-security-is-not-up-a-tricky-error/

Chances are that if you downloaded the XS CLI from the landing page in CAL you have an outdated version. I have had that error happen to me with that same image and it was sovled by downloading the latest version. Once there, you can log in with xs and list xs apps. However, you should also be able to access XS administration provided that you have the proper role collections for your user.

Cheers,

Lucia Subatin.

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi Lucia,

thank you very much for your hint. Yes, the CLI version I used was the one provided by the Developer Edition. I downloaded the latest version from SAP marketplace and it works - but for some who do not have a s-user (or download permission) this is an entry barrier. Yesterday I was a bit irritated by mentioning another port but when you say this is an internal one then I am fine :-)

Why the XSA admin ui was not reachable? This was easy - I did not recognize that by using the link on the webpage of the Developer Edition the IP was used, and not the hostname. Replaced IP by hostname and it works well now.

Thanks again.

Kind regards

Martin

0

Awesome! I get your point on the client form the marketplace. It is also available with the HANA Express download manager, though it will take you some more steps before you get it. Is the SDS connection working too?

Cheers,

Lucia.

0

Hi Lucia,

yes, the SDS connection is working pretty well. But as HXE SP01 is now available I try to migrate to new HXE - let's see what comes out.

Thx again for your help.

Cheers,

Martin

0