Skip to Content
Former Member
Nov 29, 2006 at 02:01 PM

Flight Tutorial JCO connection



I tried to run the flight tutorial but I am not able to create the JCO connection. Our R3 system is running on a different machine. I configured the sld and I was able to create the JCO connection WD_FLIGHTLIST_MODELDATA_DEST. But when I create the JCO connection WD_FLIGHTLIST_RFC_METADATA_DEST I receive during testing the error message$Exception: (102) RFC_ERROR_COMMUNICATION: Connect to message server host failed Connect_PM TYPE=B MSHOST=dev16-sv GROUP=PUBLIC R3NAME=S3E MSSERV=sapmsS3E PCS=1 ERROR service 'sapmsS3E' unknown TIME Wed Nov 29 14:59:15 2006 RELEASE 700 COMPONENT NI (network interface) VERSION 38 RC -3 MODULE ninti.c LINE 530 DETAIL NiPGetServByName2: service 'sapmsS3E' not found SYSTEM CALL getservbyname_r COUNTER 1

I also create in transaction SMLG the logon group PUBLIC. I read a lot of threads which handle this topic but I never read that someone really solved this problem.

Do I have to make some more changes at the R3 system (maybe in transaction SM59). I also put the line

sapmsS3E 3600/tcp

into the service file. Will be 3600 the port of the message server?

Kind regards