Skip to Content

BAPI L_TO_CONFIRM_SU error

Dear All,

I would need help with one BAPI issue related to WM. We are trying to implement WM with HU management. We have AFS enabled SAP solution in our system. We have developed custom RF screens for which we are using BAPI to perform the transaction.

We are creating nested handling units - Cartons and then Pallets. These pallets Handling Units form the Storage Unit numbers at WM sloc which is HU managed. One Pallet has 42 EA of material with 14 cartons of 6 cartons of one grid/batch, 4 of second grid/batch and 4 of third grid/batch packed at non HU location (1 carton = 3 EA of material). The pallet is then transferred and put away in WM location.

We create Delivery for 42 quantity with 18 qty of one grid, 12 qty of second grid and 12 qty of third grid and create picking group for 2 step picking. then we create Pick TO and system suggest this pallet created above for picking and TO is created with 3 line items - one line item per batch/grid. I have created Pick HU for the TO as well. While trying to confirm first line item 0001 of TO through BAPI L_TO_CONFIRM_SU, system is giving error - HU data for TO item 0002 are missing.

My question is while i am trying to confirm the first line item of TO, why BAPI is checking second line item for HU data? Same scenario happens when there are two or more open Pick TO line items which refer to same pallet for picking. BAPI works otherwise for all pallets where i do not come across this situation.

Do i need to set any additional indicator in BAPI? As of now i am passing only I_SQUIT = X and I_COMMIT_WORK = X along with necessary information.

Please help. Its really urgent!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Apr 17, 2017 at 08:47 PM

    I think you are saying that all the 3 lines of the TO are nested together in a single HU, correct? If that is the case, it will not let you move a portion of it without you telling the system what you are doing with the rest of the HU. Have tried this in LT11... does it give you the same error?

    Add comment
    10|10000 characters needed characters exceeded