Skip to Content
avatar image
Former Member

Unable to get all the Dynamic LOV in Crystal Reports

Hi Team,

We have a CR report that are using Dynamic LOV.

When running this report in Production does not pull all the LOV when we try to view it on Demand.

So far below steps have been performed to get the missing values:

  • To increase the maximum number of values for a dynamic parameter list of values, set the registry key: MaxRowsetRecords, to a value greater than 1,000

For 64- bit :

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\...

HKEY_LOCAL_MACHINE\SOFTWARE\SAP BusinessObjects\Suite XI 4.0\Crystal Reports\DatabaseOptions\LOV

  • Added LOV Key,it was not present
  • Add the String value: MaxRowsetRecords
  • set it to 200000

With the above steps I was able to get the LOV in DEV and UAT however Prod I am not able to get the list in Prod.

Difference between PROD and other two environment is only that Dev is a Single node and UAT and Prod is a Cluster Environment.

UAT it seems to be working but not in prod.

Is there anything that is being missed?

Is there a way where in I can find out what is missing in Prod.

Thanks in advance.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Apr 17, 2017 at 05:35 PM

    Make sure to change the registry key "MaxRowsetRecords" on all the nodes of Production where Crystal Reports 2013 Processing Server is running.

    Note: the registry key is for the case when you see the list but not the whole list. You wrote:

    "I am not able to get the list in Prod." . If you do not see a list at all, then it could be a different problem.

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 18, 2017 at 12:59 PM

    Hi Sumeet,


    If you are sure that the registry entries are same as that of QA and DEV, then it should work. However did you try to restart the SIA or the server box and then check?


    I have seen that sometimes the registry changes does not take effect and requires a restart.

    Thanks,

    Megh

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 18, 2017 at 10:21 PM

    Create a system ennvironment variable, BOE_CRLOVMAXSIZE, and set the value for the number of list of values to display, for example 200000, on all Production servers.
    BOE_CRLOVMAXSIZE = 200000

    See SAP KB 1218588 - How to increase the number of values in a dynamic parameter in Crystal Reports?

    Regards,
    Jin-Chong

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 18, 2017 at 05:05 AM

    Hi Vitaly,

    Thank you so much for your reply.

    I am able to see the list, but not the entire list of LOV. Also crystal Report Services are running on only 1 node out of 5 node cluster and the above registry key is added on that node still it does not render the complete LOV .

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 18, 2017 at 05:05 AM

    Hi Vitaly,

    Thank you so much for your reply.

    I am able to see the list, but not the entire list of LOV. Also crystal Report Services are running on only 1 node out of 5 node cluster and the above registry key is added on that node still it does not render the complete LOV .

    Add comment
    10|10000 characters needed characters exceeded

    • Sumeet,

      There is one more potential reason why the registry key may not work - If there is a

      "MaxRowsetRecords" key exists in the User's profile.

      You need to check what is the Username SIA is running under. Then login with this Username to the Server machine and check the following registry key:

      HKEY_CURRENT_USER\SOFTWARE\SAP BusinessObjects\Suite XI 4.0\Crystal Reports\DatabaseOptions\LOV

      If there is a "MaxRowsetRecords" key present you need to update it as well.

      Crystal Reports reads the Local Machine first and then checks CurrentUser. The Current User value overwrites the Local Machine value.

  • avatar image
    Former Member
    Apr 21, 2017 at 05:20 AM

    Thanks Jin and Megh for your reply we had weekly restart for your production server last week and now I could see the LOV.

    Add comment
    10|10000 characters needed characters exceeded